Closed Bug 1631281 Opened 2 years ago Closed 2 years ago

If "Open tabs" suggestion is disabled, top sites in address bar doesn't show open top sites

Categories

(Firefox :: Address Bar, defect, P2)

75 Branch
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 77
Iteration:
77.2 - Apr 20 - May 3
Tracking Status
firefox77 --- verified

People

(Reporter: yoasif, Assigned: bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image 8xxnzpbmnpt41.jpg

From: https://www.reddit.com/r/firefox/comments/g42asi/when_disabling_switch_to_tab_feature_on_address/

Steps to reproduce:

  1. Ensure YouTube is in top sites
  2. Open YouTube
  3. Ensure "Open tabs" suggestion is disabled for address bar
  4. open new tab, navigate to any other site
  5. Click on address bar

What happens:

YouTube doesn't appear in the top sites suggestions in the address bar.

Expected result:

YouTube appears; clicking the suggestion opens it without switching to existing tab.

This is interesting given the use case in the reddit post. However, personally, I'd probably argue that a user who doesn't want open tabs to show up, also doesn't want it to show up if it's a top site.

FWIW, here's the corresponding code: https://searchfox.org/mozilla-central/rev/a4d62e09a4c46aef918667fa759bf9ae898dc258/browser/components/urlbar/UrlbarProviderTopSites.jsm#146

We handle it differently, for open tabs we just don't show them as open tabs (provided they are in history or bookmarks), being open doesn't influence frecency.
Based on our current handling this is a bug.

Blocks: 1630275
Points: --- → 2
Priority: -- → P2
Points: 2 → 3
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 77.2 - Apr 20 - May 3
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4c523474446e
Show Top Sites regardless of suggest.openpage and suggest.bookmark pref values. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

I verified this issue using Fx 77.0a1 (2020-04-30) on Windows 10 x64 and macOS 10.13.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.