Closed Bug 1631332 Opened 3 years ago Closed 2 years ago

Crash in [@ IPCError-browser | RecvCreateWindow Unexpected aChromeFlags passed]

Categories

(Core :: DOM: Content Processes, defect, P3)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- wontfix
firefox78 --- fixed

People

(Reporter: gsvelto, Assigned: nika)

References

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-099576d3-d54e-4e3a-ac52-7f2600200416.

Top 10 frames of crashing thread:

0  @0x317ca4d9f84 
1  @0x317ca4f1642 
2  @0x1712060a48f 
3  @0x317ca4f1642 
4  @0x17120daf567 
5  @0x317ca5063ab 
6  @0x17120daee2f 
7  @0x317ca4f1642 
8  @0x17120dab377 
9  @0x317ca4f1642 

We're failing here. The oldest affected buildid is 20200409131623.

Nika, any idea what to make of this? The volume is very low, but it looks like it is a regression.

Flags: needinfo?(nika)
Priority: -- → P3
Severity: -- → critical

This is an initial step. In the future it may be nice to avoid loading remote
tabs within windows without useRemoteTabs in general.

Assignee: nobody → nika
Status: NEW → ASSIGNED
Flags: needinfo?(nika)
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3a84a223cf67
Block attempts to open windows from remote tabs without useRemoteTabs, r=kmag
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Duplicate of this bug: 1629527
Crash Signature: [@ IPCError-browser | RecvCreateWindow Unexpected aChromeFlags passed] → [@ IPCError-browser | RecvCreateWindow Unexpected aChromeFlags passed] [@ IPCError-browser | RecvCreateWindow New BrowsingContext has mismatched LoadContext]
You need to log in before you can comment on or make changes to this bug.