Closed Bug 1631437 Opened 5 months ago Closed 5 months ago

Authentication method not updated for selected SMTP server in Account Settings

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68+ fixed)

RESOLVED FIXED
Thunderbird 77.0
Tracking Status
thunderbird_esr68 + fixed

People

(Reporter: carbenium, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Open "Outgoing Server (SMTP)" and select a server.

Actual results:

Authentication method in details pane remains empty.

Console shows following message:

TypeError: document.getElementById(...) is null 4 am-smtp.js:184:12
updateServerInfoBox chrome://messenger/content/am-smtp.js:184
onSelectionChanged chrome://messenger/content/am-smtp.js:47
onselect chrome://messenger/content/am-smtp.xul:1
_fireOnSelect chrome://global/content/elements/richlistbox.js:332
selectItem chrome://global/content/elements/richlistbox.js:463
onxblmousedown chrome://global/content/bindings/richlistbox.xml:125
MsgAccountManager chrome://messenger/content/accountUtils.js:290
oncommand chrome://messenger/content/messenger.xul:1

Expected results:

Authentication method should be displayed.

WFM on trunk.

Trunk has commented out the failing code. See https://github.com/mozilla/releases-comm-central/commit/f86746da336942adc03b5fec7ead429627f17e29#diff-6676100a77117f1ce51f8da04b34e5c8R181

On released 68.7 it is definitely failing with the above mentioned stack trace.

I think this was left in the wrong place in bug 1538409. Then bug 1610445 commented it out...

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9143718 - Flags: review?(khushil324)

Do we also need a patch for ESR68 also?

Yes, I can take care of that, it's just removing the part that was commented on trunk.

Comment on attachment 9143718 [details] [diff] [review]
bug1631437_smtp_auth.patch

Review of attachment 9143718 [details] [diff] [review]:
-----------------------------------------------------------------

Changes look good. r=khushil
Attachment #9143718 - Flags: review?(khushil324) → review+

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ed17a22ae3d9
fix display of smtp authentication method. r=khushil

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

We should uplift to 68. It's a regression from another uplift (bug 1538409)

Regressed by: 1538409
Target Milestone: --- → Thunderbird 77.0

For ESR.

Attachment #9143914 - Flags: approval-comm-esr68?
Comment on attachment 9143914 [details] [diff] [review]
bug1631437_smtp_auth-ESR68.patch

Good in beta, so approved for ESR
Attachment #9143914 - Flags: approval-comm-esr68? → approval-comm-esr68+
Duplicate of this bug: 1635726
Keywords: regression
You need to log in before you can comment on or make changes to this bug.