If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

roxio.com - drop-down menus don't work

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
RESOLVED INVALID
15 years ago
3 years ago

People

(Reporter: Tony Tovar, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
I don't know if this is a weird Javascript error, or tech evangelism.

Using build 2002-08-14 on WinNT, the Roxio.com customer-support request page
doesn't work correctly.  If you fill-in the first several fields, then select a
s/w program, the rest of the drop-down fields are inaccessible.  On IE, there's
a quick update as -- I assume -- the fields auto-populate with the applicable
version numbers, etc.

Comment 1

15 years ago
Its a JavaScript error indeed,because I opened the JavaScript console and there
were loads of warnings.The people at roxio.com should fix their code.

Comment 2

15 years ago
This is an Evangelism issue; the problem is indicated below:


function populateVersion(index){
    if(index == -1) {
       if(navigator.appName != "Microsoft Internet Explorer")
	  return;
       index = 0;
       document.form1.product.options[0].selected=true;
    }
    document.form1.version.options.length = products[index].length;
    for(var i=1; i<products[index].length; i++) {
	    document.form1.version.options[i].value = "";
	    document.form1.version.options[i].value = products[index][i];
	    document.form1.version.options[i].text = products[index][i];
    }
    document.form1.version.options[0].selected=true;


    document.form1.purchaseMethod.options.length = obtain[index].length;
    for(var i=1; i<obtain[index].length; i++) {
	    document.form1.purchaseMethod.options[i].value = "";
	    document.form1.purchaseMethod.options[i].value = obtain[index][i];
	    document.form1.purchaseMethod.options[i].text = obtain[index][i];
    }
    document.form1.version.options[0].selected=true;



    document.form1.operatingSystem.options.length = os[index].length;
    for(var i=1; i<os[index].length; i++) {
	    document.form1.operatingSystem.options[i].value = "";
	    document.form1.operatingSystem.options[i].value = os[index][i];
	    document.form1.operatingSystem.options[i].text = os[index][i];
    }
    document.form1.version.options[0].selected=true;

    document.form1.helpTopic.options.length = help[index].length;
    for(var i=1; i<help[index].length; i++) {
	    document.form1.helpTopic.options[i].value = "";
	    document.form1.helpTopic.options[i].value = help[index][i];
	    document.form1.helpTopic.options[i].text = help[index][i];
    }
    document.form1.version.options[0].selected=true;


    if(navigator.appName == "Netscape"){
	history.go(0);   <<<----------------------------- THIS IS THE PROBLEM
    }
}



So - in Mozilla they call history.go(0) for some reason, 
and this makes the selectboxes revert to their original,
initialized values: so it looks like they never get populated.

In Mozilla, notice the throbber in the upper-right corner of
the browser. Whenever you choose a software product in the 
first selectbox, you can see the throbber running as the 
|history.go(0)| command is executed -

This only happens in browsers like NN4.x/N6/N7/Mozilla,
which all have |navigator.appName| = "Netscape".
Assignee: rogerl → aruner
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → US Ecommerce
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: pschwartau → bclary
Version: other → unspecified

Comment 3

15 years ago
Note this is the same problem as in bug 154211,
"eFax 'Contact Us' page doesn't work"

Here are some comments from that bug which may help:


------- Additional Comment_ #2 From Phil Schwartau 2002-06-25 17:49 ------- 

                            SUMMARY

1. The parent selectbox is "Category"; the user makes a choice here
2. The child selectbox is "Subject". The list of options in this list
   is set dynamically from the Category choice via the function updateList()
3. The updateList() function works just fine, but in the Netscape codepath, 
   concludes with history.go(0)
4. In NN4.7, the history.go(0) preserves the contents of both the
   parent and child selectboxes. 
5. In current Mozilla builds, the contents of the parent selectbox
   are preserved, but the dynamic contents of the child selectbox
   are reloaded to the values they had on initial page load -


------- Additional Comment_ #3 From Radha Kulkarni 2002-06-26 11:43 ------- 

I would suggest using location.reload() instead of history.go(0),
as the behavior of history.go(0) has changed in NS6.x and mozilla.
It would also be good to find out why a history.go(0) is done in the
first place for NS4.7. Maybe it was done to work around a bug in NS4.x
which is no longer necessary in NS6.x.

Comment 4

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 5

4 years ago
URL forwards to a another page. STR doesn't fit there.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.