Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: carineh00, Assigned: kmcclusk)

Tracking

({perf})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020813 Netscape/7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020813 Netscape/7.0

In http://www.sohu.com/, and on any website with marquees in general, marquees
take up to 8% each  of CPU load. Is there any way to optimize this?

Reproducible: Always

Steps to Reproduce:
1. Open Page.
2.
3.




Other sites: 
http://www.chinabyte.com/
http://www.phoenixtv.com/home/0,1328,1-1,00.html
->Layout
Assignee: Matti → attinasi
Component: Browser-General → Layout
QA Contact: asa → petersen

Comment 2

16 years ago
Well, do not use them...

No dupe

==> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago

Updated

16 years ago
QA Contact: petersen → moied
(Assignee)

Comment 3

16 years ago
patch for bug 164931 should help. 
Assignee: attinasi → kmcclusk
Depends on: 164931
(Assignee)

Comment 4

16 years ago
patches for bug 164931 and bug 132759 which have landed on the trunk should have
reduced the CPU usage for Marquee and pages with Flash Animations.

carineh00@netscape.com: Can you try your Marquee tests again using a current
trunk build?
(Reporter)

Comment 5

16 years ago
I tried to run the tests in the 10/21 trunk build, but the marquee seems to be
broken in the trunk: text appears static. The marquee works in the Branch of
10/21. You can go to the following sites and quickly test this:
http://www.sohu.com/
http://www.sina.com.cn/  
http://www.chinabyte.com
(Assignee)

Comment 7

16 years ago
Tested on WinXP 750Mhz AMD.

10/21/2002 cvs trunk build 
--------------------------
sohu 9-21%
sina 41-62%
china 16-35%

IE 6.0
------
sohu 6-9%
sina 57%-92%
china 12%-50%

N7
--
sohu 18-25%
sina 61-80%
china 26-77%

The numbers look better. But Its hard to tell if its loading the same page 
each time. There is so much going on because each page contains a combination 
of flash, marquee and animated gifs. A better test would be to have an 
isolated Marquee.

Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

16 years ago
I have attached the results of my tests. I have taken CPU load both with Flash
enabled and with Flash disabled, and have also indicated the # of marquees on
each page. All results are taken with today's trunk. It seems that, roughly, we
are burning 2%-4% CPU load per marquee, which is a nice drop from 8%!
(Reporter)

Comment 9

16 years ago
Created attachment 103659 [details]
Test Results
(Assignee)

Updated

16 years ago
Keywords: nsbeta1+
You need to log in before you can comment on or make changes to this bug.