Closed Bug 1631594 Opened 2 years ago Closed 2 years ago

Add option to keep location field unscaled on focus

Categories

(Firefox :: Address Bar, enhancement)

75 Branch
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1585912

People

(Reporter: joshas, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Click in location bar or focus it with Ctrl+L

Actual results:

Location bar input field changes side, becomes bigger.

Expected results:

Please add an option to keep location bar same size as its unfocused state.

Hi,

I'm setting component to Firefox - Address Bar for someone to take a look at this suggestion.

Thanks.

Status: UNCONFIRMED → NEW
Component: Untriaged → Address Bar
Ever confirmed: true

This has been discussed and filed many times, we'll add a pref to disable opening top sites on focus in bug 1627858 but we won't add a pref to disable urlbar field expansion (again, the reasons have been expressed multiple times).

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1585912

Could you share a link to discussion where decision was made to expand location bar on focus? I'm interested in reasons behind that logic.

You need to log in before you can comment on or make changes to this bug.