Leaks went up 2.5x around 8/1. ftp?

VERIFIED DUPLICATE of bug 162959

Status

()

VERIFIED DUPLICATE of bug 162959
16 years ago
16 years ago

People

(Reporter: mcafee, Assigned: Matti)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
[from alecf mail]
So I was just looking on tinderbox, and realized that our leaks are 
up to **797KB* *- that's almost a megabyte!

Curious how long we had been there, I looked over some of the graphs 
on tegu, and noticed this:
http://tegu.mozilla.org/graph/query.cgi?tbox=backupboy&testname=trace_malloc_leaks&autoscale=1&size=&units=bytes&ltype=&points=&showpoint=&avg=1&days=20

That's right - sometime around 8/2/2002 leaks jumped from ~330k to 
our current ~795k - that's a huge jump! Has anyone investigated why 
this happened, what checkins there were?

--

[from alecf]
Ok, so I looked and there were exactly 2 changes:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=MozillaTinderboxAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&hours=2&date=explicit&mindate=8%2F1%2F2002+15%3A35&maxdate=8%2F1%2F2002+16%3A22&cvsroot=%2Fcvsroot

so its either the change to using the FTP directory, or its the 
accessibility stuff - my guess is its the change to the FTP directory, 
but that sucks cuz it means that FTP directories leak like crazy, and 
probably always have :)

[from mcafee]

Late 8/1, I changed the ftp url since ftp://ftp.mozilla.org/Welcome
was only on one (some?) of the round-robin ftp servers.  The bloat
tests had all been orange a few days before that, or they were
flaking (sometimes orange, sometimes green).
(Reporter)

Updated

16 years ago
Keywords: mlk
(Reporter)

Comment 1

16 years ago
the bug that fixed the ftp url for the bloat test was bug 160465.
alecf filed this as bug 162959 earlier

*** This bug has been marked as a duplicate of 162959 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
Component: Browser-General → Networking: File
QA Contact: asa → benc

Comment 3

16 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
Component: Networking: File → Networking: FTP
You need to log in before you can comment on or make changes to this bug.