Closed Bug 1632299 Opened 1 year ago Closed 11 months ago

ContentDelegate.onContextMenu() not invoked when long pressing on Google image search

Categories

(Web Compatibility :: Mobile, defect)

All
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 975444

People

(Reporter: amejiamarmol, Unassigned)

Details

This event is not getting triggered for larger views but for small individual items onContextMenu is invoked see the Fenix issue for STR https://github.com/mozilla-mobile/fenix/issues/9484.

esawin to try and reproduce but possibly this is a site issue

Flags: needinfo?(esawin)

The Google Image result page serves GeckoView a page where the top "image" is not accessible by long-pressing.
Changing the user agent to Chrome solves this issue.

Component: General → Mobile
Flags: needinfo?(esawin)
OS: All → Android
Product: GeckoView → Web Compatibility
Hardware: Unspecified → All

This is essentially a duplicate of Bug 975444, and there's some recent promising progress there.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 975444
You need to log in before you can comment on or make changes to this bug.