Closed Bug 1632331 Opened 2 years ago Closed 2 years ago

Mail list's name is not updated in the directory tree (on the left) after editing it in the edit dialog

Categories

(Thunderbird :: Address Book, enhancement)

enhancement
Not set
normal

Tracking

(thunderbird_esr78 fixed)

RESOLVED FIXED
Thunderbird 80.0
Tracking Status
thunderbird_esr78 --- fixed

People

(Reporter: abdallah.khaled.ali.93, Assigned: darktrojan)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.113 Safari/537.36

Steps to reproduce:

1- Open Address Book Window from Daily
2- Right click on a mail list
3- Edit its name and press ok

Actual results:

The name of the mail list is not updated immediately on the side bar (directory tree).
I need to close the whole address book window and re-open it.

Expected results:

It would be nice to update the name immediately to show the user that the name is updated successfully

I think a simple rebuild() of the directory tree can do the work.

I'm not quite sure what's going on here, but I think the row map contains a stale copy of the directory.

Assignee: nobody → geoff

(In reply to Geoff Lankow (:darktrojan) from comment #2)

I'm not quite sure what's going on here, but I think the row map contains a stale copy of the directory.

Geoff, thank you very much for looking into these things, great job!!! Please also check this for contacts side bar. Same symptoms as bug 1644084 (but not fixed by that afasics): When renaming a mailing list in contacts side bar, entire AB content tree disappears, and I have to click "All Address Books" again to display it.

Contacts Side Bar seems to be stale more often than not - focus an unselected item in contacts sidebar, move mouse away, press Shift+Tab, results in bogus double focus on AB item and search box. Move mouse over item, and stale item focus ring disappears.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/6c471c28d027
Fix updating the tree of address books when one changes. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 80.0

Comment on attachment 9160893 [details]
Bug 1632331 - Fix updating the tree of address books when one changes. r?pmorris

Low impact, low risk, has a test.

Attachment #9160893 - Flags: approval-comm-esr78?

Comment on attachment 9160893 [details]
Bug 1632331 - Fix updating the tree of address books when one changes. r?pmorris

[Triage Comment]
Approved for esr78

Attachment #9160893 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.