Closed Bug 1632399 Opened 1 year ago Closed 7 months ago

Menu bar items / drop down menus in content do not show hover highlight when hovered over

Categories

(Core :: Widget: Gtk, defect)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- disabled

People

(Reporter: yoasif, Assigned: jhorak)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Noticed that in File, Edit, View, Tools, Help menus, menu items do not highlight on hover, making it look like the menu items cannot be activated.

Also just noticed that this applies to dropdown menus in web content, so this is a lot worse than I thought previously.

Clicking on the items work, except for submenus.

Steps to reproduce:

  1. Enable menu bar or press alt
  2. Click on any of File, Edit, View, Tools, Help menus
  3. Hover over menu items.

OR

  1. Edit this bug page
  2. Click any of the drop downs

What happens:

Menu items do not become highlighted when hovered over.

Expected result:

Menu items are highlighted when hovered over, submenus are accessible.

35:38.84 INFO: No more integration revisions, bisection finished.
35:38.84 INFO: Last good revision: b3dc4544df1f551d462e4ff6559c37b72b8269b6
35:38.84 INFO: First bad revision: 57400551129c73bf1a5b738e7fa03d331c02601d
35:38.84 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=b3dc4544df1f551d462e4ff6559c37b72b8269b6&tochange=57400551129c73bf1a5b738e7fa03d331c02601d

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1623974
Summary: Some menu items do not show hover highlight when hovered over → Menu bar items / drop down menus in content do not show hover highlight when hovered over
Attached file about:config

Thanks for the report, could you let us know:

  1. x11 or wayland
  2. your monitor scale factor/monitor setup (dual monitors?)
  3. font scale factor
  4. does keyboard navigation by arrows works, do it highlight the items?
  1. Wayland
  2. single display, 100% scale
  3. 1.00 (per GNOME Tweaks, not sure this is what you were looking for)
  4. Items do not get highlighted when using arrow keys on the keyboard; selecting items via keyboard works, but I am operating blind.

And the distro, gtk3 version, compositor/desktop environment, please?

Ubuntu focal 20.04
GNOME 3.3.6.1

apt-cache policy mutter
mutter:
Installed: 3.36.1-3ubuntu3

apt-cache policy gnome-shell
gnome-shell:
Installed: 3.36.1-5ubuntu1

apt-cache policy libgtk-3-0
libgtk-3-0:
Installed: 3.24.18-1ubuntu1

I experience the same issues (confirmed also with a fresh profile) and mozregression points towards the same commit

Arch Linux (up to date)
Gnome 3.36.1 Wayland
gtk3 3.24.18

Laptop with no additional Screen
1600x900
Font Scaling 1.0

Also:
Moving between submenus (eg: View->Toolbars, back to View, repeat) makes Firefox to not respond anymore and sometimes makes the page go white. Alt-Tabbing somehow fixes this.
The problem also applies to context menus, submenus sometimes do not show while the highlighting sometimes works but sometimes only in the top level context menu.
The Saved passwords dropdown (when there are multiple entries for the page) does not show at all.

The Password thing seems to have been something else as it is working again.

Jan, AFAIK you're running KDE, could you try to reproduce this? Just want to make sure Mutter is not at fault here (will also try on Weston / wlroots later).

Flags: needinfo?(jan)

$ GDK_BACKEND=wayland mozregression --launch 2019-10-01 -a https://www.w3schools.com/tags/tryit.asp?filename=tryhtml_select
I went back to 2019-10-01 and even there I wasn't able to hover entries of a <select> menu or of the main menu. Arrow keys also don't highlight other entries. I guess I'm seeing bug 1584845/bug 1593481. Of course it works with XWayland.

Debian Testing
plasma-desktop (4:5.17.5-3)
libgtk-3-0 (3.24.18-1)
1 Macbook Pro screen: 2560x1600, 1.0x scaling, 60 Hz
Font settings: Enforced DPI: 192

In general: KDE/Wayland is broken enough that I kept using X11 for the moment. Copy/Paste works with Nightly/XWayland, but not with Nightly/Wayland (bug 1567762). (I can't even clear the clipboard, the last entry always stays.)

Flags: needinfo?(jan)
See Also: → 1632519

Bug 1632519 sounds similar, but has a different regression range.

Jan, it looks like a regression from Bug 1623974 (the popups).

Assignee: nobody → jhorak
Flags: needinfo?(jhorak)

Just to ask it: Can this be fixed by disabling widget.wayland_vsync.enabled? (bug 1629140/bug 1542808)
(Maybe these popups now think that they are invisible? I have no idea what I'm talking about. That was my impression on KDE: I could increase webgl and video frame rate by constantly hovering different taskbar entries, otherwise it was 2 fps - probably caused by changing seconds of my clock.)

Yes, widget.wayland_vsync.enabled=false fixes the issues for me.

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #12)

(Maybe these popups now think that they are invisible? I have no idea what I'm talking about. That was my impression on KDE: I could increase webgl and video frame rate by constantly hovering different taskbar entries, otherwise it was 2 fps - probably caused by changing seconds of my clock.)

This sounds like a compositor bug - apparently not sending frame callbacks when it should. Mind creating an issue for it (checking kwinFT might be a option, too)?

btw. Bug 1632519 is about to revert widget.wayland_vsync.enabled to false. Let's switch it back when mutter is fixed.

(In reply to Thomas H from comment #13)

Yes, widget.wayland_vsync.enabled=false fixes the issues for me.

Also works for me.

Flags: needinfo?(jhorak)
Blocks: 1629140

On sway/wlroots, the same issue can be reproduced, and has been bisected to be caused by the same change.

On sway, observations are:

  1. Interaction with second-level drop-downs cause browser-wide stalls. E.g., right-click -> send to device -> hover over the last elements. These will not show hover.
  2. Interaction with some first-level drop-downs in the menu bar cause the issue described above (e.g. "Tools"), but others work until second-level drop-downs are focused (e.g. "File").
  3. Once triggered, certain aspects of rendering seems to have stalled. New context menus tend to not open, and the browser toolbar is unresponsive, not showing opening of new tabs.
  4. Re-focusing the window tends to fix it.

I have not dug further into the issue, and have only just bisected my way to it living with it for a while.

Duplicate of this bug: 1642920
Duplicate of this bug: 1655980

This was likely a duplicate of bug 1619246 - Asif, can you confirm it's fixed in >=83 beta?

Flags: needinfo?(yoasif)

I haven't seen this in a long time.

Flags: needinfo?(yoasif)

Okay, Thanks.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.