Closed Bug 163240 Opened 18 years ago Closed 16 years ago

msn.com - DellNet by MSN new user signup page's buttons are unresponsive

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: d_yerrick, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020812
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020812

Dell.com offers six months of free Internet access through DellNet by MSN
with the purchase of a home computer.  However, clicking on the "Continue"
button or the "Check for Numbers" button in the order process has no effect
at all.

Reproducible: Always

Steps to Reproduce:
This bug will be very expensive to test.

1. Buy a new computer from Dell.com.
2. Begin the DellNet by MSN signup process at
https://bbrac.msn.com/nationwide/nb/msnsignup.asp?cc=0&rpn=DELL&rsn=DELL&p=DELL6MOSRAC
3. Enter your information.
4. 

Actual Results:  
A black dotted line (which I'm assuming is the focus
indicator) appeared around the "Continue" button, but nothing else happened.

Expected Results:  
Mozilla should have gone on
to the next screen in the signup process.

Feel free to
* change this to an Evangelism bug if it turns out that Microsoft is
  coding only for its own browsers.  This is quite possible, as Microsoft
  claims that MSN dial-up access requires x86 hardware, a Windows
  98/Me/2K/XP operating system, and IE 5 or later.
* mark this bug Security Sensitive if the URL lets unauthorized users
  access the free offer and Dell or Microsoft objects.  MSN provides only
  two months of free dial-up access; DellNet by MSN provides an additional
  four months.
Erratum:

  4.

should be

  4. Click the "Continue" button or the "Check for Numbers" button with the
     primary mouse button.
->Evangelism.
The page has been created with an old version of Dreamweaver and besides that,
it tries to access the form in a propietary way without specifying document. and
uses window.event

Error: frmNewUserForm is not defined
Source File:
https://bbrac.msn.com/nationwide/nb/msnsignup.asp?cc=0&rpn=DELL&rsn=DELL&p=DELL6MOSRAC
Line: 232
Assignee: jst → aruner
Status: UNCONFIRMED → NEW
Component: DOM Other → US Ecommerce
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: gerardok → bclary
Hardware: PC → All
Version: other → unspecified
mine
Assignee: aruner → bclary
Blocks: MS
contacted
Status: NEW → ASSIGNED
Summary: DellNet by MSN new user signup page's buttons are unresponsive → msn.com - DellNet by MSN new user signup page's buttons are unresponsive
Target Milestone: --- → Nov
Keywords: evang500
tech evang june 2003 reorg
Component: US Ecommerce → English US
Target Milestone: Nov → ---
->default
Assignee: bc → english-us
Status: ASSIGNED → NEW
QA Contact: bc → english-us
Looks like the DellNet thing is gone but I can traverse the pages fine for a
normal MSN signup. Fixed.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.