Closed Bug 1632616 Opened 3 months ago Closed 3 months ago

Download and install Chrome for Android using tooltool

Categories

(Testing :: Raptor, task, P1)

Version 3
task

Tracking

(firefox77 fixed)

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: sparky, Assigned: sparky)

References

Details

Attachments

(1 file)

This bug is for implementing the tooltool method of downloading and installing the google chrome for android APK.

This patch changes how Google Chrome for Android is deployed. Rather than relying on automatic updates, we will use tooltool to download the APK and install it ourselves. Some changes were done in taskcluster to remove a hack that was put in place to disable interal tooltool downloads (the issue is resolved now).

A tooltool manifest is added for this, and to keep ourselves organized, all manifests (including the playback ones) are moved into a folder called tooltool-manifests.

Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/2550dcabbedf
Download and install google chrome through tooltool. r=aerickson,perftest-reviewers,Bebe
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.