Closed Bug 1632807 Opened 2 years ago Closed 2 years ago

[Windows 7] Stub Installer cannot be installed on a clean environment

Categories

(Firefox :: Installer, defect, P1)

77 Branch
Desktop
Windows 7
defect

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox77 --- verified

People

(Reporter: mberlinger, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image ss.png

Affected versions

  • 77.0a1(2020-04-24)

Affected platforms

  • Windows 7x86

Steps to reproduce

  1. Download the targeted Firefox Stub Installer.
  2. Run Firefox Stub Installer.
  3. Click "Yes" on the UAC Prompt.

Expected result

  • The Installation starts.

Actual result

  • An error message is displayed saying that “Firefox Nightly Installer has stopped working”

Regression range

  • Don’t think this is a regression since it is part of the new feature.

Additional notes

  • I used a clean environment for this (all mozilla appdata and registries were emptied before running the stub installer)
  • A Stub Installer 74 version works fine.
  • See the attached screenshot with the error message.

Please note that the issue is reproducible on win 7 x64 as well.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b3f18a01096
Keep the WebBrowser plugin DLL from being unloaded after creating a timer. r=agashlin
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

The issue was verified fixed using the latest Fx 77.0a1.
The stub installer now correctly installs Firefox, no longer hanging or crashing on Windows 7 x64 and x32.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.