Closed Bug 1633294 Opened 5 months ago Closed 5 months ago

Creation of multiple mail list with the same name

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 78.0

People

(Reporter: abdallah.khaled.ali.93, Assigned: abdallah.khaled.ali.93)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.122 Safari/537.36

Steps to reproduce:

in Address book window :

1 - Create a mailing list named 'My List 1'
2- Create another mailing list named 'My List 1'

Actual results:

The second list is created without any guard or alert of duplication

Expected results:

an alert prompt should have appeared preventing the user from using a duplicate name

This is due to the fact that in file abMailListDialog.js, the canonical name is sent to the function MailServices.ab.mailListNameExists although this function compares the string as is and does not preform tolower() on all list names before comparison

Assignee: nobody → abdallah.khaled.ali.93

Hello,

I opened this bug but I do not how to change its status to NEW instead of UNCONFIRMED. Would you please help ?

Flags: needinfo?(mkmelin+mozilla)

Hey, automation already took care of it for you.

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(mkmelin+mozilla)

Thank you

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/e920d59017e1
Prevent the creation of a mailing list with a duplicate name. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 78.0
You need to log in before you can comment on or make changes to this bug.