mozilla 1.0.1rc1 hangs in XFS

RESOLVED WORKSFORME

Status

()

Core
Internationalization
--
critical
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Dawn Endico, Assigned: Shanjian Li)

Tracking

({hang, intl})

Trunk
x86
Linux
hang, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Linux qualm.mi.org 2.4.18-5smp #1 SMP Mon Jun 10 15:19:40 EDT 2002 i686 unknown
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020815
redhat 7.3

This has happened two or 3 times now since i started using 1.0.1rc1.
I use mozilla for several hours and then at some seemlingly random point
mozilla hangs while loading a page. Then after a minute or two, the
whole machine hangs. After leaving the system alone for some time
the system has killed the mozilla process and the machine works fine
again.

Twice now in the period between mozilla hanging and the system hang
xfs was listed first by 'top. Next was kswapd then X. Mozilla was
#5 or 6.


the last time this happened, i got these console messages. I guess
the font warnings are related, but maybe not.

$ Warning: Cannot convert string "<Key>Escape,_Key_Cancel" to type VirtualBinding
Warning: Cannot convert string "<Key>Home,_Key_Begin" to type VirtualBinding
Warning: Cannot convert string "<Key>F1,_Key_Help" to type VirtualBinding
Warning: Cannot convert string "Shift<Key>F10,_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>F10,Shift_Key_Menu" to type VirtualBinding
Warning: Cannot convert string "<Key>KP_Enter,_Key_Execute" to type VirtualBinding
Warning: Cannot convert string "Alt<Key>Return,Alt_Key_KP_Enter" to type
VirtualBinding
/home/endico/mozilla/101rc1/run-mozilla.sh: line 72:  9214 Killed              
   $prog ${1+"$@"}
(Reporter)

Updated

16 years ago
Keywords: hang

Comment 1

16 years ago
The console messages are from the java plugin and are printed the first time you
encounter a java applet.

The general behavior you have described is typically caused by Mozilla
recursively chewing up memory.  
1. Mozilla hangs
2. system hangs (too much swapping)
3. system runs out of memory and kernel kills Mozilla (and maybe other things as
well)

did you happen to note Mozilla's memory usage while this was going on?

Updated

16 years ago
Severity: normal → critical
Keywords: intl
QA Contact: ruixu → ylong
Sounds like out-of-control memory allocation until VM is filled.  Is there disk
activity during this?  Any messages in /var/log/messages?  core files?

You might want to leave a 'top' running.

Comment 3

16 years ago
> Twice now in the period between mozilla hanging and the system hang
> xfs was listed first by 'top. Next was kswapd then X. Mozilla was
> #5 or 6.

This sounds like moz is asking for a scaled font from xfs. Xfs could be 
struggling because of a bug in xfs or moz asking for a very large pixel size.

Could you set the environment variable NS_FONT_DEBUG=DC, capture the output,
and attach the last part (<1000 lines) of it to this bug?

If possible a reproducable case would really speed the diagnosis.
Assignee: yokoyama → shanjian
I wonder if this is the same thing that some people have reported to me. 
Sometimes, when people search on google, the resulting page causes mozilla to
allocate memory like crazy and hang.  I've never been able to reproduce it
myself, but the stacks that I've seen almost always end up in the font code,
making an X call to load a font.

Comment 5

16 years ago
Does the problem go away when xfs gets disabled and the font path is passed to
the Xserver directly ?

Comment 6

14 years ago
Is this hanging bug still occuring?

Comment 7

12 years ago
Does this and other very old XFS bugs still exist?  Or can they be closed?
bug 92590 
bug 103493 
bug 187473 
bug 203735 
Summary: mozilla 1.0.1rc1 hangs → mozilla 1.0.1rc1 hangs in XFS

Comment 8

12 years ago
not enough info to go on here... resolving WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.