readme.txt and license.txt missing

VERIFIED FIXED

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: Bugzilla-alanjstrBugs, Assigned: dveditz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020818

I did a "browser only" installation.  Shorcuts were created pointing to
readme.txt and license.txt in "C:\Program Files\mozilla.org\Mozilla".  Neither
file is in there.  There is no readme.txt at all under that directory tree, but
a license.txt exists in "C:\Program Files\mozilla.org\Mozilla\Setup\".

Comment 1

16 years ago
Confirmed 2002081808/winXP
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Missing readme and license happens in NT 4.0 also.
There is a readme and license icon in
START->Program Files->Mozilla->readme.txt(and license)
right where is should be, but no files.
With "Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2a) Gecko/20020910"

Same bug (after custom install).
-> Insaller (?)
Assignee: Matti → dveditz
Component: Browser-General → Installer
QA Contact: asa → bugzilla
*** Bug 169218 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 175141 has been marked as a duplicate of this bug. ***
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20021016"

Same bug (after custom install).

Comment 8

16 years ago
Created attachment 103747 [details] [diff] [review]
Fix for problem

Actually, this should be all that is needed.

We need to put the readme and license in the bin directory.

All the other code is already in place to make this happen.

Comment 9

16 years ago
Adding seawood for review since this in an xpfe/bootstrap Makefile change.
Comment on attachment 103747 [details] [diff] [review]
Fix for problem

If you don't need that OS2 ifdef, remove it before you check it in. r=cls
Attachment #103747 - Flags: review+

Comment 11

16 years ago
I was told that README.TXT was only for the top three platforms, so if I wanted 
OS/2 readme stuff, it couldn't go there.

So other platforms that want READMEs will have to put them somewhere else and 
then have an if to copy them instead of README.TXT.

I put this there as kind of an example as to what the right thing to do would 
be.

I'm going to try to get permission to check in a readme.os2 so this code will 
actually work.
Comment on attachment 103747 [details] [diff] [review]
Fix for problem

a=dbaron for trunk checkin
Attachment #103747 - Flags: approval+

Comment 13

16 years ago
This bug is fixed.

Verified on current nightly.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 14

16 years ago
verified on 1106 nightly
Status: RESOLVED → VERIFIED
"Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2) Gecko/20021126"

Fixed :-)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.