Crash on startup on GKPLUGIN.DLL

VERIFIED DUPLICATE of bug 163228

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 163228
16 years ago
16 years ago

People

(Reporter: David G King, Assigned: rubydoo123)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020816
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020816

Whenever I started Mozilla, I got a crash on GKPLUGIN.DLL (See talkback
TB9526354X for most information).

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. See crash


Actual Results:  
Crash

Expected Results:  
To see my beloved Mozilla running.

OK, here are all the details, in all their horrid glory.

While investigating, I found that Netscape 4.79 was also crashing on startup
(but on MSVCRT.DLL). After lots of mucking around (and many talkback reports,
which I stopped sending after a while) I found the problem was with a DLL in the
Netscape 4.79 Plugin directory.

To be specific, the NPQ00732.DLL which is part of the Quick View Plus for
Windows plug-in, crashes Mozilla when it appears in Netscape 4.79.

So, what's my problem, well the fact that a plug-in installed into a different
brower crashes Mozilla. OK, so it's Netscape, but still...
(Reporter)

Comment 1

16 years ago
Created attachment 95786 [details]
The DLL causing the problem

This is NPQ00732.DLL which is what was crashing Mozilla when in the Netscape
4.79 Plugin directory.

Updated

16 years ago
Keywords: crash, stackwanted

Comment 2

16 years ago
may be dupe of bug 163228.
Whiteboard: [has TB ID] TB9526354X

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 163228 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified DUPE

Stack from incident #9526354
-----------------------------
nsPluginHostImpl::WritePluginInfo
[c:/builds/seamonkey/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp, line
5342]
nsPluginHostImpl::FindPlugins
[c:/builds/seamonkey/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp, line
5216]
nsPluginHostImpl::LoadPlugins
[c:/builds/seamonkey/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp, line
5044]
nsPluginHostImpl::GetPluginFactory
[c:/builds/seamonkey/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp, line
4559]
nsJVMManager::StartupJVM
[c:/builds/seamonkey/mozilla/modules/oji/src/nsJVMManager.cpp, line 671]
nsJVMManager::MaybeStartupLiveConnect
[c:/builds/seamonkey/mozilla/modules/oji/src/nsJVMManager.cpp, line 902]
nsJVMManager::StartupLiveConnect
[c:/builds/seamonkey/mozilla/modules/oji/src/nsJVMManager.h, line 144]
nsJSEnvironment::Init
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1702]
NS_CreateScriptContext
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1748]
nsDOMSOFactory::NewScriptContext
[c:/builds/seamonkey/mozilla/dom/src/build/nsDOMFactory.cpp, line 156]
nsDocShell::EnsureScriptEnvironment
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 6407]
nsWebShell::GetInterface
[c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp, line 303]
nsGetInterface::operator()
[c:/builds/seamonkey/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp, line 55]
nsCOMPtr_base::assign_from_helper
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 81]
nsDocShell::InternalLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 4675]
nsDocShell::LoadURI [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 687]
nsDocShell::LoadURI [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 2387]
nsWebShellWindow::Initialize
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 343]
nsAppShellService::JustCreateTopWindow
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 717]
nsAppShellService::CreateHiddenWindow
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 419]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1480]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1876]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1894]
WinMainCRTStartup()
KERNEL32.DLL + 0x1b560 (0xbff8b560)
KERNEL32.DLL + 0x1b412 (0xbff8b412)
KERNEL32.DLL + 0x19dd5 (0xbff89dd5)
Status: RESOLVED → VERIFIED
Keywords: stackwanted
Whiteboard: [has TB ID] TB9526354X
You need to log in before you can comment on or make changes to this bug.