Closed Bug 1633797 Opened 1 year ago Closed 11 months ago

Perma Late beta TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERRO R_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12 when Gecko 77 merges to Beta on 2020-05-04

Categories

(Core :: DOM: Editor, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- fixed
firefox78 --- verified

People

(Reporter: aiakab, Assigned: masayuki)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:Central as Beta simulation.

https://treeherder.mozilla.org/#/jobs?repo=try&selectedTaskRun=XeZH2tJLQxO1iJw0n1ffnA-0&resultStatus=testfailed%2Cbusted%2Cexception%2Crunnable&revision=23aad667ce7d6484b613f646537ef087cf12f514&searchStr=mochitest

https://treeherder.mozilla.org/logviewer.html#?job_id=299810087&repo=try

https://firefoxci.taskcluster-artifacts.net/XeZH2tJLQxO1iJw0n1ffnA/0/public/logs/live_backing.log

[task 2020-04-28T15:48:44.805Z] 15:48:44 INFO - TEST-START | editor/libeditor/tests/test_bug1425997.html
[task 2020-04-28T15:48:44.862Z] 15:48:44 INFO - TEST-INFO | started process screentopng
[task 2020-04-28T15:48:45.454Z] 15:48:45 INFO - TEST-INFO | screentopng: exit 0
[task 2020-04-28T15:48:45.455Z] 15:48:45 INFO - Buffered messages logged at 15:48:44
[task 2020-04-28T15:48:45.455Z] 15:48:45 INFO - must wait for load
[task 2020-04-28T15:48:45.455Z] 15:48:45 INFO - Buffered messages finished
[task 2020-04-28T15:48:45.455Z] 15:48:45 INFO - TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERROR_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12
[task 2020-04-28T15:48:45.455Z] 15:48:45 INFO - focusedOrLoaded/<@http://mochi.test:8888/tests/SimpleTest/SimpleTest.js:918:23
[task 2020-04-28T15:48:45.456Z] 15:48:45 INFO -
[task 2020-04-28T15:48:45.456Z] 15:48:45 INFO - simpletestOnerror@SimpleTest/SimpleTest.js:1950:18
[task 2020-04-28T15:48:45.456Z] 15:48:45 INFO - GECKO(10796) | JavaScript error: http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html, line 49: NS_ERROR_FAILURE:
[task 2020-04-28T15:48:45.456Z] 15:48:45 INFO - GECKO(10796) | MEMORY STAT | vsize 2565MB | residentFast 142MB | heapAllocated 22MB
[task 2020-04-28T15:48:45.457Z] 15:48:45 INFO - TEST-OK | editor/libeditor/tests/test_bug1425997.html | took 76ms
[task 2020-04-28T15:48:45.457Z] 15:48:45 INFO - TEST-START | editor/libeditor/tests/test_bug1497480.html
[task 2020-04-28T15:48:49.357Z] 15:48:49 INFO - GECKO(10796) | MEMORY STAT | vsize 2567MB | residentFast 142MB | heapAllocated 21MB
[task 2020-04-28T15:48:49.357Z] 15:48:49 INFO - TEST-OK | editor/libeditor/tests/test_bug1497480.html | took 4442ms

Masayuki could be this regressed by Bug 1632724

Flags: needinfo?(masayuki)
Priority: -- → P3
Summary: Perma TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERRO when Gecko 77 merges to Beta on 2020-05-04R_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12 → Perma TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERRO R_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12 when Gecko 77 merges to Beta on 2020-05-04

Is it running as early beta or late beta? I guess that it fails only on late beta due to bug 1611374.

Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Flags: needinfo?(masayuki) → needinfo?(aiakab)

Okay, I confirmed that this is reproducible with the pref change.

Flags: needinfo?(aiakab)

Our editor's deletion code removes nodes step-by-step. Therefore, even when
somebodies call DeleteSelectionWithTransaction() for removing non-collapsed
ranges, they may have already removed all contents in the range. In such
case, all callers shouldn't call DeleteSelectionWithTransaction().

This makes test_bug1425997.html allow to run nexted execCommand. It'll be
disabled even in the release channel, but we should keep testing it for
detecting bug of edge cases (like this bug). Note that all crashtests which
test nested execCommand calls run with allowing it with the pref for same
reason.

Attachment #9144932 - Attachment description: Bug 1633797 - Make callers of `EditorBase::DeleteSelectionWithTransaction()` if selection is collapsed but the caller tries to delete non-collapsed range r=m_kato! → Bug 1633797 - Make callers of `EditorBase::DeleteSelectionWithTransaction()` stop calling it if selection is collapsed but the caller tries to delete non-collapsed range r=m_kato!

Bug 1632724 should be in the "Regressed by" field.

Flags: needinfo?(masayuki)
Flags: needinfo?(masayuki)
Regressed by: 1632724
No longer regressions: 1632724
Severity: -- → S2
Pushed by masayuki@d-toybox.com:
https://hg.mozilla.org/integration/autoland/rev/8740667be31e
Make callers of `EditorBase::DeleteSelectionWithTransaction()` stop calling it if selection is collapsed but the caller tries to delete non-collapsed range r=m_kato
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Please request a beta uplift.

Flags: needinfo?(masayuki)
Summary: Perma TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERRO R_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12 when Gecko 77 merges to Beta on 2020-05-04 → Perma Late beta TEST-UNEXPECTED-FAIL | editor/libeditor/tests/test_bug1425997.html | uncaught exception - NS_ERRO R_FAILURE: at @http://mochi.test:8888/tests/editor/libeditor/tests/test_bug1425997.html:49:12 when Gecko 77 merges to Beta on 2020-05-04

Comment on attachment 9144932 [details]
Bug 1633797 - Make callers of EditorBase::DeleteSelectionWithTransaction() stop calling it if selection is collapsed but the caller tries to delete non-collapsed range r=m_kato!

Beta/Release Uplift Approval Request

  • User impact if declined: new permanent orange only in late-beta stage and release channel.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just making the test setting pref explicitly rather than using default value which is different between early beta or earlier and late beta and release.
  • String changes made/needed: no
Flags: needinfo?(masayuki)
Attachment #9144932 - Flags: approval-mozilla-beta?

Comment on attachment 9144932 [details]
Bug 1633797 - Make callers of EditorBase::DeleteSelectionWithTransaction() stop calling it if selection is collapsed but the caller tries to delete non-collapsed range r=m_kato!

Uplift approved for the next beta, thanks.

Attachment #9144932 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.