Closed Bug 1633802 Opened 4 years ago Closed 4 years ago

Graphical error/flickering when scrolling on ubuntu 18.04 (OpenGL=affected, WebRender=unaffected)

Categories

(Core :: Graphics, defect)

75 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox75 --- disabled

People

(Reporter: julian, Unassigned)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Sometimes (fortunately?) when scrolling a website up and down. It is not website specific. The website in the video is heise.de.

Actual results:

Graphical errors/flicking are appearing. The patterns and size of it are always different, but somewhat consistent in one session. Usually restarting Firefox solves the issue. Please see the attached video.

Expected results:

No graphical errors.

Severity: normal → --
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Clarifying question: Wayland or X11?

Flags: needinfo?(julian)

Please open about:support, click on "Copy text to clipboard" and paste it here.

Do you use any display scale?

Attached file about:support

Thanks for the quick replies! I'm not using any display scale.

Please open about:config, set layers.acceleration.force-enabled (the deprecated OpenGL compositor) to false and gfx.webrender.all (the new OpenGL compositor) to true and restart Firefox. WebRender is active if you see "Compositing: WebRender" on about:support. Does WebRender fix this problem?

Thanks for the help. I change it, but it will take a few days for me confirm, if anything has changed, since the bug only shows up sporadically.

Flags: needinfo?(jan)

The graphical didn't show up again. You can close the bug. Thank you very much and keep up the great work! :)

Thanks for the confirmation! :)

Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Component: Widget: Gtk → Graphics
Depends on: fixed-by-webrender
Flags: needinfo?(julian)
Flags: needinfo?(jan)
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Resolution: --- → WONTFIX
Summary: Graphical error/flickering when scrolling on ubuntu 18.04 → Graphical error/flickering when scrolling on ubuntu 18.04 (OpenGL=affected, WebRender=unaffected)
You need to log in before you can comment on or make changes to this bug.