Closed Bug 1633850 Opened 4 months ago Closed 3 months ago

Intermittent devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | No network requests appear in the network panel - Got 1, expected 0

Categories

(DevTools :: Framework, defect, P5)

defect

Tracking

(firefox78 fixed)

RESOLVED FIXED
Firefox 78
Tracking Status
firefox78 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: daisuke, NeedInfo)

References

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disabled])

Attachments

(2 files)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=299842349&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/PIjWrfLZSP-36Qq8D8fn6g/runs/0/artifacts/public/logs/live_backing.log


[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | No network requests appear in the network panel - Got 1, expected 0
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - Stack trace:
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochikit/content/browser-test.js:test_is:1297
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_ignore_toolbox_network_requests.js:null:25
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1039
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1074
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:904
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:918
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - Leaving test bound
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - Console message: [JavaScript Warning: "Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect." {file: "resource://devtools/client/netmonitor/src/components/request-list/RequestListHeader.js" line: 545}]
[task 2020-04-28T18:38:30.260Z] 18:38:30 INFO - GECKO(10316) | JavaScript error: , line 0: uncaught exception: Object
[task 2020-04-28T18:38:30.261Z] 18:38:30 INFO - GECKO(10316) | JavaScript error: resource://devtools/client/netmonitor/src/connector/firefox-data-provider.js, line 622: Error: Error while calling method getEventTimings: 'getEventTimings' active request packet to 'server0.conn5.netEvent4' can't be sent as the connection just closed.
[task 2020-04-28T18:38:30.266Z] 18:38:30 INFO - TEST-PASS | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | The main process DevToolsServer has no pending connection when the test ends -
[task 2020-04-28T18:38:30.266Z] 18:38:30 INFO - Console message: [JavaScript Error: "uncaught exception: Object"]
[task 2020-04-28T18:38:30.266Z] 18:38:30 INFO - Console message: [JavaScript Error: "Error: Error while calling method getEventTimings: 'getEventTimings' active request packet to 'server0.conn5.netEvent4' can't be sent as the connection just closed." {file: "resource://devtools/client/netmonitor/src/connector/firefox-data-provider.js" line: 622}]
[task 2020-04-28T18:38:30.266Z] 18:38:30 INFO - Not taking screenshot here: see the one that was previously logged

Oh, thank you very much for letting me know.
Yes, I'll take a look at this.

Hi Honza!
I investigated a bit, but I found some weird points, please let me ask a question.

First, if we do this test manually, I think it will be like following STRs.

  1. Open a web page that has CSS. (e.g. https://www.mozilla.org/en-US/ )
  2. Wait until the document is loaded
  3. Open DevTools
  4. Select Style Editor
  5. Wait until CSS files are loaded into StyleEditor
  6. Select Netmonitor

After that, it seems that the test expects that Netmonitor has no any network requests in the panel.
However, we do the above STRs manually, the network requests of CSS loaded by Style Editor are displayed in Nightly and even Release Edition (75).
I think this is unexpected behavior, but am I correct??

If so, I'd like to confirm and ask some questions.
That is, do we intend to restrict showing network requests loaded by DevTools? If so, I'd like to know where we restrict.
If we don't intend that anymore, I'll remove this test :)
(And I imagine the reason why the test was failed is that the timing was changed by introducing ResourceWatcher)

Could you confirm this?

Flags: needinfo?(daisuke) → needinfo?(odvarko)
Assignee: nobody → rmaries
Status: NEW → ASSIGNED

This bug is on our disable-recommended filter. Daisuke, should we land this patch until there will be a fix?

Flags: needinfo?(daisuke)

Hi Razvan!
Yes, as I'm not sure how much time we take to fix this, please apply your patch.

Flags: needinfo?(daisuke)
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6d22bfa58da
Disabled browser_ignore_toolbox_network_requests.js on multiple platforms. r=aryx
Whiteboard: [stockwell disabled] → [retriggered][stockwell disabled]

(In reply to Daisuke Akatsuka (:daisuke) from comment #5)

Hi Honza!
I investigated a bit, but I found some weird points, please let me ask a question.

First, if we do this test manually, I think it will be like following STRs.

  1. Open a web page that has CSS. (e.g. https://www.mozilla.org/en-US/ )
  2. Wait until the document is loaded
  3. Open DevTools
  4. Select Style Editor
  5. Wait until CSS files are loaded into StyleEditor
  6. Select Netmonitor

After that, it seems that the test expects that Netmonitor has no any network requests in the panel.
However, we do the above STRs manually, the network requests of CSS loaded by Style Editor are displayed in Nightly and even Release Edition (75).

Yep, I see two requests for CSS in 76
I don't see any when testing m-c

I think this is unexpected behavior, but am I correct??

Yes, I don't see any reason why we should display requests done internally by DevTools in the Network panel (they should be visible in the BrowserToolbox Network panel, but that's different story)

If so, I'd like to confirm and ask some questions.
That is, do we intend to restrict showing network requests loaded by DevTools? If so, I'd like to know where we restrict.

This is done here:
https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/devtools/server/actors/network-monitor/network-observer.js#65

The matchRequest should filter out all requests that are NOT executed by the web-page itself.

If we don't intend that anymore, I'll remove this test :)
(And I imagine the reason why the test was failed is that the timing was changed by introducing ResourceWatcher)

I am seeing that StyleEditor fetches the stylesheets here
https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/devtools/server/actors/stylesheets.js#194

According to the comment there, the fetch should use the system principal (not content principal).
The request should not be done like it's been executed by the page.

@Gabriel can you confirm, is this the place where the StyleEditor fetches the source if it isn't available?

Honza

Flags: needinfo?(odvarko) → needinfo?(gl)

In the last 7 days there have been 25 occurrences, all on macosx1014-64 debug.

Recent failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=301533877&repo=autoland&lineNumber=9510

[task 2020-05-09T11:09:16.970Z] 11:09:16     INFO - TEST-START | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js
[task 2020-05-09T11:09:17.002Z] 11:09:17     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x13aa34800 == 3 [pid = 2932] [id = {91a5a6d6-dedc-404c-8724-523b426f89ff}]
[task 2020-05-09T11:09:17.002Z] 11:09:17     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 7 (0x11ad556f0) [pid = 2932] [serial = 11] [outer = 0x0]
[task 2020-05-09T11:09:17.002Z] 11:09:17     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 8 (0x13aa35c00) [pid = 2932] [serial = 12] [outer = 0x11ad556f0]
[task 2020-05-09T11:09:17.165Z] 11:09:17     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 9 (0x13db46400) [pid = 2932] [serial = 13] [outer = 0x11ad556f0]
[task 2020-05-09T11:09:17.423Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x10a35c000 == 12 [pid = 2930] [id = {717dca88-18be-2d4f-8062-e3735932efad}]
[task 2020-05-09T11:09:17.423Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 26 (0x129adf6a0) [pid = 2930] [serial = 52] [outer = 0x0]
[task 2020-05-09T11:09:17.423Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 27 (0x15634c800) [pid = 2930] [serial = 53] [outer = 0x129adf6a0]
[task 2020-05-09T11:09:17.501Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4285
[task 2020-05-09T11:09:17.502Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 28 (0x15bfc8000) [pid = 2930] [serial = 54] [outer = 0x129adf6a0]
[task 2020-05-09T11:09:17.589Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005 (NS_ERROR_FAILURE): file /builds/worker/checkouts/gecko/dom/base/nsContentUtils.cpp, line 3733
[task 2020-05-09T11:09:17.714Z] 11:09:17     INFO - GECKO(2930) | [Child 2933: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 8 (0x10d35bc00) [pid = 2933] [serial = 5] [outer = 0x0] [url = about:blank]
[task 2020-05-09T11:09:17.714Z] 11:09:17     INFO - GECKO(2930) | [Child 2933: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x10d366c00 == 2 [pid = 2933] [id = {088d1c4e-c261-7541-9ee0-259001bcb1ab}] [url = about:blank]
[task 2020-05-09T11:09:17.714Z] 11:09:17     INFO - GECKO(2930) | [Child 2933: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x10616a400 == 1 [pid = 2933] [id = {0fb49786-4436-044c-b6f6-a1313b553966}] [url = data:text/html,<html><head><title>Test Disable F12 experiment</title></head><body><h1>Disable F12 experiment</h1></body></html>]
[task 2020-05-09T11:09:17.715Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x15a525800 == 13 [pid = 2930] [id = {44a76d02-ab4b-1747-919d-0bc8e8df8b09}]
[task 2020-05-09T11:09:17.715Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 29 (0x12e3436a0) [pid = 2930] [serial = 55] [outer = 0x0]
[task 2020-05-09T11:09:17.715Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 30 (0x15c823c00) [pid = 2930] [serial = 56] [outer = 0x12e3436a0]
[task 2020-05-09T11:09:17.715Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4285
[task 2020-05-09T11:09:17.814Z] 11:09:17     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005 (NS_ERROR_FAILURE): file /builds/worker/checkouts/gecko/dom/base/nsContentUtils.cpp, line 3733
[task 2020-05-09T11:09:18.311Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x128011c00 == 14 [pid = 2930] [id = {c1a467fb-212f-6b40-9b9c-4133a845cb83}]
[task 2020-05-09T11:09:18.311Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 31 (0x15a5eca40) [pid = 2930] [serial = 57] [outer = 0x0]
[task 2020-05-09T11:09:18.311Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, nullptr) failed with result 0x804B000A (NS_ERROR_MALFORMED_URI): file /builds/worker/checkouts/gecko/extensions/permissions/Permission.cpp, line 46
[task 2020-05-09T11:09:18.311Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: '!principal', file /builds/worker/checkouts/gecko/netwerk/cookie/CookieJarSettings.cpp, line 190
[task 2020-05-09T11:09:18.312Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/checkouts/gecko/toolkit/components/antitracking/StorageAccess.cpp, line 40
[task 2020-05-09T11:09:18.369Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_TRUE(presShell) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4283
[task 2020-05-09T11:09:18.370Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 32 (0x1280f8800) [pid = 2930] [serial = 58] [outer = 0x15a5eca40]
[task 2020-05-09T11:09:18.969Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x1280edc00 == 15 [pid = 2930] [id = {e961d569-c541-614a-b367-db2529acec94}]
[task 2020-05-09T11:09:18.970Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 33 (0x12e344350) [pid = 2930] [serial = 59] [outer = 0x0]
[task 2020-05-09T11:09:18.970Z] 11:09:18     INFO - GECKO(2930) | [Parent 2930: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 34 (0x1316b0000) [pid = 2930] [serial = 60] [outer = 0x12e344350]
[task 2020-05-09T11:09:19.020Z] 11:09:19     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4285
[task 2020-05-09T11:09:19.314Z] 11:09:19     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 8 (0x11ad27400) [pid = 2932] [serial = 6] [outer = 0x0] [url = about:blank]
[task 2020-05-09T11:09:19.315Z] 11:09:19     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x101e62800 == 2 [pid = 2932] [id = {4732c4b5-de69-694d-b2d0-301aa4329744}] [url = data:text/html,<html><head><title>Test Disable F12 experiment</title></head><body><h1>Disable F12 experiment</h1></body></html>]
[task 2020-05-09T11:09:19.315Z] 11:09:19     INFO - GECKO(2930) | [Child 2932: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x113b57000 == 1 [pid = 2932] [id = {866ded37-49b7-bc48-a3d4-476a6d3fe52b}] [url = about:blank]
[task 2020-05-09T11:09:19.320Z] 11:09:19     INFO - GECKO(2930) | [Child 2938: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (0x12472a000) [pid = 2938] [serial = 3] [outer = 0x0] [url = about:blank]
[task 2020-05-09T11:09:19.904Z] 11:09:19     INFO - TEST-INFO | started process screencapture
[task 2020-05-09T11:09:20.419Z] 11:09:20     INFO - TEST-INFO | screencapture: exit 0
[task 2020-05-09T11:09:20.419Z] 11:09:20     INFO - Buffered messages logged at 11:09:16
[task 2020-05-09T11:09:20.419Z] 11:09:20     INFO - Entering test bound 
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/framework/test/doc_viewsource.html
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Buffered messages logged at 11:09:17
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Tab added and finished loading
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 78}]
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Buffered messages logged at 11:09:18
[task 2020-05-09T11:09:20.420Z] 11:09:20     INFO - Console message: [JavaScript Warning: "Use of nsIFile in content process is deprecated." {file: "resource://gre/modules/NetUtil.jsm" line: 253}]
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - TEST-PASS | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | correct number of editors opened - 
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - Buffered messages finished
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | No network requests appear in the network panel - Got 1, expected 0
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - Stack trace:
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochikit/content/browser-test.js:test_is:1327
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochitests/content/browser/devtools/client/framework/test/browser_ignore_toolbox_network_requests.js:null:25
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1064
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1104
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:927
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:918
[task 2020-05-09T11:09:20.421Z] 11:09:20     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: '!inner', file /builds/worker/checkouts/gecko/dom/ipc/JSWindowActorProtocol.cpp, line 172
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - GECKO(2930) | [Parent 2930, Main Thread] WARNING: '!inner', file /builds/worker/checkouts/gecko/dom/ipc/JSWindowActorProtocol.cpp, line 172
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Leaving test bound 
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Console message: [JavaScript Warning: "Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect." {file: "resource://devtools/client/netmonitor/src/components/request-list/RequestListHeader.js" line: 545}]
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Console message: [JavaScript Error: "Content Security Policy: The page’s settings blocked the loading of a resource at inline (“default-src”)." {file: "chrome://global/content/elements/panel.js" line: 78}]
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - GECKO(2930) | JavaScript error: , line 0: uncaught exception: Object
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - GECKO(2930) | JavaScript error: resource://devtools/client/netmonitor/src/connector/firefox-data-provider.js, line 622: Error: Error while calling method getEventTimings: 'getEventTimings' active request packet to 'server0.conn8.netEvent5' can't be sent as the connection just closed.
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - TEST-PASS | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | The main process DevToolsServer has no pending connection when the test ends - 
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Console message: [JavaScript Error: "uncaught exception: Object"]
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Console message: [JavaScript Error: "Error: Error while calling method getEventTimings: 'getEventTimings' active request packet to 'server0.conn8.netEvent5' can't be sent as the connection just closed." {file: "resource://devtools/client/netmonitor/src/connector/firefox-data-provider.js" line: 622}]
[task 2020-05-09T11:09:20.422Z] 11:09:20     INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - TEST-UNEXPECTED-FAIL | devtools/client/framework/test/browser_ignore_toolbox_network_requests.js | A promise chain failed to handle a rejection: 'getEventTimings' active request packet to 'server0.conn8.netEvent5' can't be sent as the connection just closed. - stack: listenerJson@resource://devtools/client/devtools-client.js:248:17
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - _emit@resource://devtools/shared/event-emitter.js:226:34
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - emit@resource://devtools/shared/event-emitter.js:172:18
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - emit@resource://devtools/shared/event-emitter.js:324:18
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - reject@resource://devtools/client/devtools-client.js:662:15
[task 2020-05-09T11:09:20.423Z] 11:09:20     INFO - purgeRequests/<@resource://devtools/client/devtools-client.js:683:53
...

I threw a patch that changes the loading principal of the connection of style editor to system principal and avoids assertion failure due to that change.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5a296ad8d52272ece5e346577020b675582bb180
As the result, it seems that the failures on the try are occured by style editor's two tests only.
Thus, I want to try to use the system principal, then fix that are broken in style editor.
If having opinions, please let me know!

I investigated this issue, the test failure below is caused by that we use the system principal even if the context is under the private browsing.
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=301395653&repo=try&lineNumber=5016
( this test devtools/client/styleeditor/test/browser_styleeditor_private_perwindowpb.js )
And, it seems that we can not create a channel that has both the system principal and private browsing context.
Thus, we may need to check an information except the system principal.

I took a look at the code.
As very easy way (but might not good way), we are set a policy TYPE_INTERNAL_STYLESHEET to the channel.
https://searchfox.org/mozilla-central/source/devtools/server/actors/stylesheets.js#207
If we can check the policy as well in network observer below, it seems we may solve it.
https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/devtools/server/actors/network-monitor/network-observer.js#76-84

Honza, what do you think? Do you have any ideas??

Flags: needinfo?(odvarko)

(In reply to Daisuke Akatsuka (:daisuke) from comment #17)

If we can check the policy as well in network observer below, it seems we may solve it.
https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/devtools/server/actors/network-monitor/network-observer.js#76-84
Honza, what do you think? Do you have any ideas??

Extending the condition and check also the TYPE_INTERNAL_STYLESHEET policy sounds reasonable to me.

Honza

Flags: needinfo?(odvarko)

Okay, thank you very much, Honza!
I'll try to fix usiung the policy.

Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5299f7340990
Use the loading policy to restrict networks of StyleEditor. r=Honza

As a patch that fixes the cause of this issue landed on m-c, I close this bug.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Keywords: leave-open
Resolution: --- → FIXED
Assignee: rmaries → daisuke

The fix didn't land on beta. Given the failure rate is low, an uplift is unlikely now (last week before release).

Flags: needinfo?(daisuke)
Target Milestone: --- → Firefox 78
Regressions: 1646974
You need to log in before you can comment on or make changes to this bug.