Closed Bug 1633942 Opened 5 months ago Closed 4 months ago

introduce HttpChannelOnStartRequestArgs

Categories

(Core :: Networking: HTTP, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: CuveeHsu, Assigned: CuveeHsu)

References

Details

(Whiteboard: [necko-triaged])

Attachments

(2 files)

We have lots of dup code for sending those args (example) and will be much more if we want to dispatch them between threads.

Note:
I was tempting to use Maybe<nsHttpResponseHead> here, but inevitably we need another copy.
On the other hand, copy constructor are called 4 times for the IPC message. Haven't taken a look to see if we can save one or two.
https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/netwerk/protocol/http/PHttpChannel.ipdl#110-111

We have a windows build failure

The problem is we include winsock2.h which is conflict with winsock.h

Not sure if the theory is true or not:
Usually, we'll define WIN32_LEAN_AND_MEAN to minimize API in winsock.h.
However, for some reason nspr need the fullset winsock api.
And we put winsock2.h to NeckoChannelParams.ipdl, which is included in PContent, which is built too early to un-include the winsock.h

I'm going to try to have another ipdlh to avoid this. Finger crossed.

(In reply to Junior from comment #4)

We have a windows build failure

The problem is we include winsock2.h which is conflict with winsock.h

Not sure if the theory is true or not:
Usually, we'll define WIN32_LEAN_AND_MEAN to minimize API in winsock.h.
However, for some reason nspr need the fullset winsock api.
And we put winsock2.h to NeckoChannelParams.ipdl, which is included in PContent, which is built too early to un-include the winsock.h

I'm going to try to have another ipdlh to avoid this. Finger crossed.

Seem working
https://treeherder.mozilla.org/#/jobs?repo=try&revision=555e316efdc476b21fa82c90acf515ee33384e7d

Depends on: 1638172
Pushed by juhsu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/244ef650bb0e
P1 introduce HttpChannelOnStartRequestArgs and ipdl changes, r=mayhemer,necko-reviewers
https://hg.mozilla.org/integration/autoland/rev/1c0ff3fd45fa
P2 pass HttpChannelOnStartRequestArgs through PHttpChannel, r=mayhemer,necko-reviewers
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.