Closed Bug 163401 Opened 20 years ago Closed 20 years ago

Marquee should be a block-level element in html.css

Categories

(Core :: Layout, defect)

x86
Windows 98
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 163031

People

(Reporter: bamm, Assigned: attinasi)

Details

Attachments

(2 files)

I am attaching two test cases illustrating why marquee should explicitly be
defined as block in html.css.

In the first test case, the top bar uses marquee while the lower bar uses an
ordinary div. Both are given gray backgrounds, and both are enclosed in a div
with a red background.

The expected result is that no red should be seen. This is because the inner
block fills in the outer block. The actual result is the marquee bar appears as
red, while the div bar appears correctly as gray.

Because marquee is block-level, it should also be gray.

The second test case is exactly the same as the first, but this time I added
a stylesheet:

  marquee {
    display: block;
  }

The top bar now appears correctly as gray.
Suggested fix:

In RCS file: /cvsroot/mozilla/layout/html/document/src/html.css,v
we need to make the following changes:

 marquee {
+  display: block;
   -moz-binding:
url('chrome://xbl-marquee/content/xbl-marquee.xml#marquee-horizontal');
 }

*** This bug has been marked as a duplicate of 163031 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
QA Contact: petersen → amar
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.