Closed Bug 1634013 Opened 4 months ago Closed 4 months ago

Remove the browser.tabs.multiselect pref

Categories

(Firefox :: Tabbed Browser, task, P3)

task

Tracking

()

RESOLVED FIXED
Firefox 77
Tracking Status
firefox77 --- fixed

People

(Reporter: dao, Assigned: aarushivij, Mentored)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(1 file)

This pref was added to control when the corresponding feature would be shipped. The feature has shipped a long time ago, so let's remove this pref:

https://searchfox.org/mozilla-central/search?q=browser.tabs.multiselect&case=true

Hello,
Can I take up this issue?
Thanks :)

(In reply to aarushivij from comment #1)

Hello,
Can I take up this issue?
Thanks :)

Sure, go ahead.

Hey Dao, just to confirm
Since the pref is going away,
So I have to remove all these lines https://searchfox.org/mozilla-central/source/browser/components/extensions/parent/ext-tabs.js#54-60?
And thus subsequently remove its usage too?
As here : https://searchfox.org/mozilla-central/search?q=gMultiSelectEnabled&path=&case=true&regexp=false
Thanks :)

Flags: needinfo?(dao+bmo)

(In reply to aarushivij from comment #3)

Hey Dao, just to confirm
Since the pref is going away,
So I have to remove all these lines https://searchfox.org/mozilla-central/source/browser/components/extensions/parent/ext-tabs.js#54-60?
And thus subsequently remove its usage too?
As here : https://searchfox.org/mozilla-central/search?q=gMultiSelectEnabled&path=&case=true&regexp=false
Thanks :)

Correct.

Flags: needinfo?(dao+bmo)
Assignee: nobody → aarushivij
Status: NEW → ASSIGNED
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1722e7d840d1
Remove the browser.tabs.multiselect pref r=dao
Regressions: 1634233
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Regressions: 1635264
No longer regressions: 1635264
You need to log in before you can comment on or make changes to this bug.