[DOGFOOD]new newsgroup not showing in folder page after subscribe (tree needs to be refreshed)

VERIFIED FIXED in M12

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] 11/19)

(Reporter)

Description

19 years ago
Used 10-13-09-M11 commercial build / WinNT platform:

1) Tried to subscribed other newsgroups "e.g. netscape.public.test" from the
news server "e.g.news.mozilla.org"
2)The subscribe dialog displayed for selecting and allowed for selecting.
3)Actual Result: After I select that specific newsgroup for that news server..
The newsgroup not displayed.

Expected Result: Should reflect the news newsgroup which already subscribed from
the subscribe dialog
Status: NEW → ASSIGNED
Summary: Newsgroups not display even after selected from the subscrib dialog → new newsgroup not showing in folder page after subscribe (tree needs to be refreshed)
ok, the news group is there, but you have to collapse and expand the news server
to see it.

the bug is the tree isn't getting refresh.

looking into that now.

changing summary to reflect bug.

Comment 2

19 years ago
If it's the first newsgroup in the server that you're subscribing to, there is
no +/- toggle.

Comment 3

19 years ago
you have to tell the folder listener for the parent folder, and that will
reflect it up into RDF.
Summary: new newsgroup not showing in folder page after subscribe (tree needs to be refreshed) → [DOGFOOD] new newsgroup not showing in folder page after subscribe (tree needs to be refreshed)
marking dogfood.

adding daver and phil to cc list.

subscribing to news is not dogfood yet.

Comment 5

19 years ago
I went to subscribe, entered the newsgroup name and then I saw it reading the
counter at the bottom of the window reading through the 7000 mail/news newsgroup
messages but they never ended up displaying.  Shouldn't the 4.x newsgroups
migrate so that I don't have to re-enter?

Updated

19 years ago
Whiteboard: [PDT+]

Comment 6

19 years ago
we don't migrate news group headers, if that's what you're asking. That would
require parsing the neo access files.

Updated

19 years ago
Blocks: 17432
Target Milestone: M12
marking m12, and accepting.

Updated

19 years ago
Summary: [DOGFOOD] new newsgroup not showing in folder page after subscribe (tree needs to be refreshed) → [DOGFOOD][Tree] new newsgroup not showing in folder page after subscribe (tree needs to be refreshed)

Comment 8

19 years ago
Marking [Tree]

Updated

19 years ago
Summary: [DOGFOOD][Tree] new newsgroup not showing in folder page after subscribe (tree needs to be refreshed) → [DOGFOOD]new newsgroup not showing in folder page after subscribe (tree needs to be refreshed)

Comment 9

19 years ago
NOT a [Tree] bug.  Sorry folks.

Updated

19 years ago
Whiteboard: [PDT+] → [PDT+] 11/19
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
fixed, thanks to putterman.
a note:  this fix is only for the case when you have a news server, with at
least one newsgroup already, and the news server is "open" and you add a new
newsgroup using subscribe.

there is a bug already that if you have folder (or news server) and it's
"closed", and you add a subfolder (or newsgroup) the twisty doesn't show up.

this is not that bug.

Comment 12

19 years ago
Seth, is there a bug filed for the twisty problem? If not, please file one.

Comment 13

19 years ago
It's bug 10208 which was marked as a dup of 8467, but apparently that wasn't the
cause because 10208 still exists.
(Reporter)

Comment 14

19 years ago
Even there was a bug#10208, I still log bug for specific newsgroup, it's
bug#18675

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Win_nt 4.0 (1999-11-16-09 M12)
This problem is fixed. the subscribed newsgroup shows up in the folder after
subscribe is done.

Updated

18 years ago
No longer blocks: 17432
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.