Closed Bug 1634690 Opened 2 years ago Closed 4 months ago

Page.navigate should return loaderId for file:* urls

Categories

(Remote Protocol :: CDP, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1632008

People

(Reporter: impossibus, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [puppeteer-beta2-mvp])

Example

            Page.navigate({"url":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html"})
Network.requestWillBeSent({"documentURL":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html","frameId":"200D0C2CAF29E73EC1EFE43577856DAB","hasUserGesture":false,"initiator":{"type":"other"},"loaderId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","request":{"headers":{},"initialPriority":"VeryHigh","method":"GET","mixedContentType":"none","referrerPolicy":"no-referrer-when-downgrade","url":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html"},"requestId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","timestamp":129913.578746,"type":"Document","wallTime":1588341412.801628})
 Network.responseReceived({"frameId":"200D0C2CAF29E73EC1EFE43577856DAB","loaderId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","requestId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","response":{"connectionId":0,"connectionReused":false,"encodedDataLength":-1,"fromDiskCache":false,"fromPrefetchCache":false,"fromServiceWorker":false,"headers":{},"mimeType":"text/html","protocol":"file","remoteIPAddress":"","remotePort":0,"securityState":"secure","status":0,"statusText":"","url":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html"},"timestamp":129913.580867,"type":"Document"})
            Page.navigate({"url":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html"}) = {"frameId":"200D0C2CAF29E73EC1EFE43577856DAB","loaderId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5"}
 Page.frameStartedLoading({"frameId":"200D0C2CAF29E73EC1EFE43577856DAB"})
      Page.frameNavigated({"frame":{"id":"200D0C2CAF29E73EC1EFE43577856DAB","loaderId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","mimeType":"text/html","securityOrigin":"file://","url":"file:///home/maja/dev/mozilla-unified/remote/test/browser/page/doc_empty.html"}})
     Network.dataReceived({"dataLength":89,"encodedDataLength":0,"requestId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","timestamp":129913.586716})
  Network.loadingFinished({"encodedDataLength":89,"requestId":"BBCEC6032D3B8C7AD1A9B2DA5954C9F5","shouldReportCorbBlocking":false,"timestamp":129913.580394})
      Page.loadEventFired({"timestamp":129913.59224})
 Page.frameStoppedLoading({"frameId":"200D0C2CAF29E73EC1EFE43577856DAB"})
Page.domContentEventFired({"timestamp":129913.592547})
Priority: -- → P3
Whiteboard: [puppeteer-beta2-mvp]
Component: CDP: Page → CDP

This got actually done via bug 1632008.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1632008
You need to log in before you can comment on or make changes to this bug.