Closed Bug 1634879 Opened 3 months ago Closed 3 months ago

Minor changes for SeaMonkey preferences

Categories

(SeaMonkey :: Preferences, enhancement)

enhancement

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.74
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: frg, Assigned: frg)

Details

(Whiteboard: SM2.53.3)

Attachments

(3 files, 3 obsolete files)

The following pref changes should be done:

  • Expose hiding the grippies in the preferences panel. The pref was added some time back but was not directly user accessible.
  • Move the "Show Zoom controls" into the zoom groupbox. The current location is not ideal. I failed to notice this when I reviewed the original bug.
  • Tabs should be visible in the browser by default. First thing I do when I create a new profile.

I wonder if we should switch default cookie setting to disallow third party settings?

Attached patch 1634879-hidegrippies-2533.patch (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: need to do the pref change via about:config
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): trivial.
String changes made by this patch: various plus help.

There is enough space at the right of "Show Tooltips" but I wonder how to show this in the Second column?

Attachment #9145210 - Flags: review?(iann_bugzilla)
Attachment #9145210 - Flags: approval-comm-release?
Attachment #9145210 - Flags: approval-comm-esr60?

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: A shrug why this is not in the right box.
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): trivial
String changes made by this patch: --

Attachment #9145211 - Flags: review?(iann_bugzilla)
Attachment #9145211 - Flags: approval-comm-release?
Attachment #9145211 - Flags: approval-comm-esr60?

Was discussed some time ago and I also stated the intention to do this in mozillaZine. No people with pitchforks appeared.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Need to change pref manually
Testing completed (on m-c, etc.): 2.53.3
Risk to taking this patch (and alternatives if risky): trivial.
String changes made by this patch: --

Attachment #9145214 - Flags: review?(iann_bugzilla)
Attachment #9145214 - Flags: approval-comm-release?
Attachment #9145214 - Flags: approval-comm-esr60?
Comment on attachment 9145211 [details] [diff] [review]
1634879-movezoompref-2533.patch

[Triage Comment]
LGTM r/a=me
Attachment #9145211 - Flags: review?(iann_bugzilla)
Attachment #9145211 - Flags: review+
Attachment #9145211 - Flags: approval-comm-release?
Attachment #9145211 - Flags: approval-comm-release+
Attachment #9145211 - Flags: approval-comm-esr60?
Attachment #9145211 - Flags: approval-comm-esr60+
Comment on attachment 9145214 [details] [diff] [review]
1634879-autohide-2533.patch

[Triage Comment]
LGTM r/a=me
Attachment #9145214 - Flags: review?(iann_bugzilla)
Attachment #9145214 - Flags: review+
Attachment #9145214 - Flags: approval-comm-release?
Attachment #9145214 - Flags: approval-comm-release+
Attachment #9145214 - Flags: approval-comm-esr60?
Attachment #9145214 - Flags: approval-comm-esr60+
Comment on attachment 9145210 [details] [diff] [review]
1634879-hidegrippies-2533.patch

>+++ b/suite/components/pref/content/pref-appearance.xul
>+    <vbox class="box-padded"
>+          align="start">
Nit: This doesn't need to be on separate line as all attributes can fit on a single line.

>+++ b/suite/locales/en-US/chrome/common/help/cs_nav_prefs_appearance.xhtml
>+  <li><strong>Hide toolbar grippies</strong>: Check this if you want to hide
>+    the <a href="glossary.xhtml#grippy">toolbar grippies</a> preventing
>+    accidental collapses of menus and toolbars if you don't use them.
Maybe "...preventing menubars and toolbars being accidentally collapsed if you are not used to grippies."?

>+++ b/suite/locales/en-US/chrome/common/help/glossary.xhtml
>+<dt id="grippy">grippy</dt><dd>A small box at the left of menus and toolbars.
Nit: "to" rather than "at" and "menubars" rather than "menus"
>+  The grippy allows the user to quickly collapse menus and toolbars.</dd>
Nit: menubars

Do we need to add menubars to the glossary? It is assumed that everyone know what Toolbars are so could the same be said of Menubars...

>+++ b/suite/locales/en-US/chrome/common/pref/pref-appearance.dtd
>@@ -15,16 +15,18 @@
> <!ENTITY picsNtextRadio.label                   "Pictures and text">
> <!ENTITY picsNtextRadio.accesskey               "P">
> <!ENTITY picsOnlyRadio.label                    "Pictures only">
> <!ENTITY picsOnlyRadio.accesskey                "o">
> <!ENTITY textonlyRadio.label                    "Text only">
> <!ENTITY textonlyRadio.accesskey                "x">
> <!ENTITY showHideTooltips.label                 "Show Tooltips">
> <!ENTITY showHideTooltips.accesskey             "T">
>+<!ENTITY showHideGrippies.label                 "Hide toolbar grippies">
Should we mention menubars too?
>+<!ENTITY showHideGrippies.accesskey             "g">
g isn't a very good accesskey due to the bottom loop, either make it "Hide Toolbar Grippies" and "G" or keep lower case and use "d" or "e" as the accesskey.

r/a=me with those addressed.
Attachment #9145210 - Flags: review?(iann_bugzilla)
Attachment #9145210 - Flags: review+
Attachment #9145210 - Flags: approval-comm-release?
Attachment #9145210 - Flags: approval-comm-release+
Attachment #9145210 - Flags: approval-comm-esr60?
Attachment #9145210 - Flags: approval-comm-esr60+
Comment on attachment 9145210 [details] [diff] [review]
1634879-hidegrippies-2533.patch

Just had a thought whilst looking at another bug. macOS doesn't show grippies anyway, so we should hide the pref UI/help on mac platform.
https://dxr.mozilla.org/comm-esr60/source/suite/themes/classic/mac/communicator/communicator.css#61
so only f+ for the moment, sorry.
Attachment #9145210 - Flags: review+
Attachment #9145210 - Flags: feedback+
Attachment #9145210 - Flags: approval-comm-release+
Attachment #9145210 - Flags: approval-comm-esr60+

Nit: This doesn't need to be on separate line as all attributes can fit on a single line.

Left it in but can fix. I find the multitem lines hard to read and would rather use single item lines for new or changes items.

Maybe "...preventing menubars and toolbars being accidentally collapsed if you are not used to grippies."?

I am used to grippies but also don't want them. Constantly hid the bar with a wrong click and find them useless with full screen available if vertical height is a problem. Left out the reason which is open to debate anyway and has nothing to do with the option itself. Used menu- and toolbars to avoid duplicating -bar. But not sure if this or the duplication is better.

Nit: "to" rather than "at" and "menubars" rather than "menus"

Fixed and reworded.

Do we need to add menubars to the glossary?

No. Toolbars was there already but doubt anyone cares.

g isn't a very good accesskey due to the bottom loop,

Fixed in this patch.

Attachment #9145210 - Attachment is obsolete: true
Attachment #9145240 - Flags: feedback?(iann_bugzilla)
Comment on attachment 9145240 [details] [diff] [review]
1634879-hidegrippies-_v1_1-2533.patch

>+++ b/suite/locales/en-US/chrome/common/help/cs_nav_prefs_appearance.xhtml
>+  <li><strong>Hide Toolbar Grippies</strong>: <span class="mac">This option is
>+    not available on macOS.</span><span class="noMac">Check this if you want to
>+    hide the <a href="glossary.xhtml#grippy">menu- and toolbar grippies</a>
I'd prefer menubar rather than menu- (I know it is implied but menubar looks better and probably easier for localisers to understand).
>+    preventing accidental collapses of menu- and toolbars.
I'd prefer menubars rather than menu- here

r/a=me with those fixed.
Attachment #9145240 - Flags: review+
Attachment #9145240 - Flags: feedback?(iann_bugzilla)
Attachment #9145240 - Flags: approval-comm-release+
Attachment #9145240 - Flags: approval-comm-esr60+

NITS corrected. menu- replaced with menubar(s) and reformatted.
r/a+ from IanN retained.

Attachment #9145240 - Attachment is obsolete: true
Attachment #9145291 - Flags: review+
Attachment #9145291 - Flags: approval-comm-release+
Attachment #9145291 - Flags: approval-comm-esr60+

Checkin comment corrected. r/a+ from IanN retained. Sorry for the bugspam.

Attachment #9145291 - Attachment is obsolete: true
Attachment #9145293 - Flags: review+
Attachment #9145293 - Flags: approval-comm-release+
Attachment #9145293 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/b7ba7cc6f093
Move zoom control pref into zoom groupbox. r=IanN
https://hg.mozilla.org/comm-central/rev/5a7e541c43e3
Show the tabstrip in the browser as default. r=IanN
https://hg.mozilla.org/comm-central/rev/14a6a6722455
Expose pref for hiding the tolbar grippies in the prefs. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.74

(In reply to Frank-Rainer Grahl (:frg) from comment #0)

  • Tabs should be visible in the browser by default.

Sorry, it is a terrible change for me.

I belongs to users who started using Mozilla/SM decades ago, when there were no tabs yet. Such users are used to always open new windows even nowadays. Probably these habits are still preserved, as many of us (at the end of our careers) can afford a fairly large monitor...

AFAIR we were even annoyed by the appearance of the tabs, and switched immediately to "A new window" in the "Link behavior", plus some kludge in userChrome.css to restore "Open Link in New Window" at the first place in the context menu (sad it was not implemented fe. by a similar pref).

I understand that it is still possible to "Hide the tab bar when only one tab is open" in Preferences, but do not quite understand why should long-term behavior now be changed? What kind of users benefit from this change? How big is amount of them? Why just now?

BTW, is it planned for a future to put tab bar above the urlbar as in FF?

Flags: needinfo?(iann_bugzilla)

Sorry, it is a terrible change for me.
...

May I answer. This is one of the options where if you ask 2 people get 4 different answers. I won't quote bogus telemetry results which are not available or used for/by SeaMonkey anway. The functionality has not changed and will not be changed. What has changed is the default pref. If you do your own builds you can set it back and no one will notice. You can also change it via the preferences dialog and it will stick. It is a one time change for a new or existing profile. You never wanted it changed. I always wanted it changed because almost every time I test something and set up a new profile I need the tab strip visible with only the occasional new window open testing.

Draw tabs in titlebar is not a planned feature. One of the things I find horrible but if someone wants to do a third new SeaMonkey theme with flippin burger menu and all the new stuff we (dis)like I would give r+ in a heartbeat but never use it. All about choice but you sometimes need to make a decision which is not pleasing everyone.

That said if people start yelling at me/us for this change it will be backed out.

Flags: needinfo?(iann_bugzilla)
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.