Installer should remember last install location

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P4
normal
VERIFIED WORKSFORME
18 years ago
2 years ago

People

(Reporter: Phil Peterson, Assigned: Sean Su)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I think in 4.x when you run the installer, it knows where on the disk you last
installed Communicator, and pre-fills that as the file location for the current
install. mozilla seems not to do that, and it would save me some typing (over
and over again) if it did.

Updated

18 years ago
Assignee: cathleen → ssu
Target Milestone: M12
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Moving non-dogfood bugs to M13

Comment 2

18 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine

Updated

18 years ago
Blocks: 22176
(Assignee)

Comment 3

18 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Build 2000-01-03-09-M13(WIN)

It bloody works!
(Reporter)

Comment 5

18 years ago
This bug seems to be back using 2000-06-02-08 commercial build on NT. Reopening.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 6

18 years ago
I can only reproduce this if I remove the last installation- if I keep it- it 
shows me that path and prompts me to delete.  If I remove it, it defaults to 
C:\Program Files\Netscape
(Reporter)

Comment 7

18 years ago
Makes sense -- I usually do delete the previous build

Updated

18 years ago
No longer blocks: 22176

Comment 8

17 years ago
Sean, 
Isn't this fixed?
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Priority: P3 → P4
Resetting target field for missed milestones
Target Milestone: M13 → ---
Severity: normal → enhancement
Summary: Installer should remember last install location → Remember last install location even if uninstalled
Updating summary to reduce confusion. In the normal case we *do* remember where
we installed last, but if it has been uninstalled the registry entry with that
info has also been uninstalled.

It's a trade off between this feature and really cleaning up after ourselves. I
suspect more people would rather have the uninstaller get rid of the registry
entries.
(Reporter)

Comment 11

17 years ago
Dan, does that mean the installer choice to delete the previous install actually
runs the uninstaller? If so, can't we just pick up the previous install location
before the uninstaller wipes it out?
(Assignee)

Comment 12

17 years ago
Phil, the choice to delete the previous version does not run the uninstaller.

I think what the new summary states is that the installer should still remember
where the last installation of Mozilla was, even if the user had ran the
uninstaller already.
(Reporter)

Comment 13

17 years ago
Ok, then I just want to point out that the bug is morphing. I originally filed
the bug on needing to re-enter the custom install location every time, after
choosing delete previous install. I wasn't talking about uninstall when I filed
the bug.
The original description was something like (summarized) "install to custom 
location. Next day start install again, should default to same location but 
doesn't".

If that's what you want, we think that works (and currently you will be 
prompted to delete the version we found at that location). Unless in between 
you have uninstalled, in which case we can't default to the location of the 
currently installed version because there isn't one anymore.

So, has the original problem regressed, or should we leave this open for the 
enhancement of remembering the custom location even though you've uninstalled?
(Reporter)

Comment 15

17 years ago
Since this bug is so old, it seems more likely that the initial problem has been
fixed along the way, rather than that it has regressed.

I just wanted to point out that this bug seemed to be morphing, especially since
the install-after-uninstall problem doesn't seem very important to me.

If this bug were assigned to me, I'd mark it worksforme and wait for a
compelling reason to solve the install-after-uninstall problem.
Changing summary back to describe Phil's original complaint, marking WORKSFORME 
per discussion. Sorry for the confusion, all!
Severity: enhancement → normal
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
Summary: Remember last install location even if uninstalled → Installer should remember last install location

Comment 17

17 years ago
Marking Verified.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.