Document continues scrolling even after mouse button released on up or down click on scroll bar arrows.

RESOLVED DUPLICATE of bug 157123

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 157123
16 years ago
15 years ago

People

(Reporter: John P. Hewitt, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
On installation toay of 1.0.1, scroll bar behavior is not normal. Clicking to
scroll up or down often produces scrolling that does not stop when mouse button
is released; instead, scrolling continues until cursor is moved onto desktop
space. Problem intermittent, but happens more often than not. Sometimes
scrolling will move document to top or bottom, other times seems to stop at a
random location. Spinning globe also appears along with this behavior. No other
problems noted. Mozilla running on iBook 600 mhz OS X 10.1.5.

Comment 1

16 years ago
I have had this problem a few times on a frames page with four frames of
streaming Java video, that also makes the scrollbar paint erroneously about
where the URL text field is...

Alas, it is a very rare event, and there is no reliable way to reproduce it
(unless some knowledgable person is willing to do some rough browsing on a
hardcore pornsite...).

Comment 2

16 years ago
John, what build ID are you reporting this bug against?
(Reporter)

Comment 3

16 years ago

Bug appears on Build ID: 2002081505

An interesting side note: in some cases (I haven't yet figured out pattern)
Mozilla won't stop loading a page and I have to stop it manually. It may be
only in these instances that the scrolling bug appears. I will check this and
report further.
JPH

Comment 4

16 years ago
WorksForMe using FizzillaCFM/2002081505 (1.0.1 RC1) to access
[http://www.mozilla.org/] and [http://www.mozillazine.org/].

Comment 5

16 years ago
Reassigning to XP Toolkit/Widgets for now.
Assignee: Matti → jaggernaut
Component: Browser-General → XP Toolkit/Widgets
QA Contact: asa → jrgm

Comment 6

16 years ago
This has been a problem on the trunk since shortly after 1.0. I think the last
builds I downloaded (1.1 "release candidates, sorry build ID not to hand but
believe ~18/08/2002) seem slightly better, but still with a significant delay
before noticing that the scroll button has been released.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

16 years ago
*** Bug 164243 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Generally there are several ways of using the scroll buttons(arrows):
1. "Fast", single click on an arrow at the scroll bar; Mozilla works well here
2. A Little longer click at the arrow (about a second long); Mozilla fails here.
It's quite easy to reproduce it: click at the arrow at the scroll bar for about
a second, release the mouse key and _DON'T_ move the mouse. Mozilla will scroll
the document until the user moves the cursor. You can try this at both:
http://bugzilla.mozilla.org/show_bug.cgi?id=163502
http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
3. Clicking the button (arrow) and holding down the mouse key. Mozilla doesn't
work well here. Instead of scrolling the document smoothly it "jumps" from one
part of the document to the other, making it impossible to see the content of
the document/page.
Of course the user may also grab the scroll bar and move it upwards or
downwards, Mozilla works well here, but it's not a "smooth scrolling". My guess
is this bug may not occur at faster machines, but it's present at my computer
(G3 500/384 RAM) which is not really an old one.
I'm using Mozilla 2002083017 for Mac OS X.

Comment 9

16 years ago
A really pesky bug, I've noticed this on all releases from 1.0.1 to 1.2a used on
MacOS X 10.1.x
It turns Mozilla user experience to a nightmare.

Comment 10

16 years ago
This also happens in Linux, Moz version 1.1

Example URL
http://www.w3.org/TR/html4/struct/tables.html

Comment 11

16 years ago
*** Bug 180395 has been marked as a duplicate of this bug. ***

Comment 12

16 years ago
Reproduceable build 20021120 7.01
http://wp.netscape.com/eng/mozilla/ns7/relnotes/7.html#problems
mouse up recognized, scrolling stops after moments
http://www.dmnforums.com/htm/homeset.htm
mouse up not recognized. scrolling continues until page ends

temporary workaround
moving mouse away from scroll initiantion point (mouse up) will stop scrolling

Comment 13

15 years ago
The problem seems to be fixed in 1.4a (2003030703), at least for me.

Comment 14

15 years ago
Isn't this bug the same as bug 157123?

Comment 15

15 years ago
Yes

*** This bug has been marked as a duplicate of 157123 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.