Closed Bug 163521 Opened 18 years ago Closed 18 years ago

client collaborative spam block support

Categories

(SeaMonkey :: MailNews: Message Display, defect, major)

defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 112315

People

(Reporter: ivo.welch, Assigned: sspitzer)

Details

spam is taking over the world.  we need frontend support in mozilla messenger to
support collaborative backend services.  on the front-end, this would be easy:

one button, preferably to the right of the "STOP" button in the messenger
client, which says "SPAM."  A panel in Mail/News Account Settings allows the
user to set multiple response actions:

---- SPAM BUTTON MEANS
* forward this spam to website <USER ENTRY W/ DEFAULT> as SPAM:
   - header only
   - entire message (compressed)
* add sender to spam block list.
* add subject to spam block list.

Once the frontend exists, my bet is that backend services will begin to appear
to build filter lists in real time fairly quickly.  (I think this is the only
real hope in the fight against spam:  user intelligence.)

Naturally, it would be nice if Mozilla Messenger would then be able to slurp
spam filter lists from this website, too; but this mechanism would need to be
thought out more deeply.  (see bug 11035).

it would also allow the poor netscape guys to make some money by offering and
maintaining a backend service that blocks spam.  hey, I would pay for good
intelligent filtering built-in.  I am really getting sick and tired off of it. 
I now get 3 spams for every real mail.
This is a dup, just search for enhacementes about "spam":
71413   enh   NEW     Spam Filter: right click on incoming mail address and
select "Block this Address"
120160 enh ASSI whitelist spam filtering
120606 enh NEW [RFE]: Spam filter: Count the number of To and/or CC addresses
121146 enh NEW Collaborate with Spamcop?
126688 enh NEW Support live download of message filter rules for spam filtering
134603 enh NEW Spam management via "filter based on inclusion in specific
address book"
151612 enh NEW [RFE] per-filter import and export (anti-spam)
151622 enh NEW [RFE] filters that score messages (anti-spam)
163188 enh NEW want Bayesian antispam filters per Paul Graham's design

*** This bug has been marked as a duplicate of 112315 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.