Search.pm calls time2str which is not found in the file

RESOLVED FIXED in Bugzilla 2.18

Status

()

RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: jussi, Assigned: jussi)

Tracking

2.17
Bugzilla 2.18

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

399 bytes, patch
bbaetz
: review+
bbaetz
: review+
Details | Diff | Splinter Review
(Assignee)

Description

16 years ago
When using a '10d' type date in the 'were changed between' field, bugzilla
reports the following error:

Undefined subroutine &Bugzilla::Search::time2str called at Bugzilla/Search.pm
line 835.

I could not duplicate this in http://landfill.bugzilla.org/bugzilla-tip/query.cgi.
(Assignee)

Comment 1

16 years ago
Created attachment 95948 [details] [diff] [review]
patch

Fixes the error by adding &:: in front of the two time2str calls.
Comment on attachment 95948 [details] [diff] [review]
patch

|use Date::Format;| at the top (just under the package line) instead
Attachment #95948 - Flags: review-
(Assignee)

Comment 3

16 years ago
Created attachment 95956 [details] [diff] [review]
patch v2

Add the use statement instead of &::
Attachment #95948 - Attachment is obsolete: true
Hmm. While this is definately the right thing to do, I can't reproduce this.

What perl version are you running?
(Assignee)

Comment 5

16 years ago
I'm running perl 5.6.1.
Hmm - so do I

Can you give a url which would trigger this, that I can copy-and-paste to my
local installation? (ie something without products/components selected)
(Assignee)

Comment 7

16 years ago
In my installation, the query in url field causes the error.

Updated

16 years ago
Attachment #95956 - Flags: review+
Comment on attachment 95956 [details] [diff] [review]
patch v2

Hmm. No idea why I couldn't reproduce this.

r=bbaetz x2, I'll check it in under the Bugzilla::Util include (for style
reasons)
-> patch author
Assignee: endico → jussi
checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.