Closed Bug 1636195 Opened 2 years ago Closed 2 years ago

Enable for javascript.options.property_error_message_fix for MOZ_DEV_EDITION

Categories

(Core :: JavaScript Engine, task, P2)

task

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox76 --- wontfix
firefox77 --- verified
firefox78 --- verified

People

(Reporter: Harald, Assigned: arai)

References

Details

Attachments

(1 file)

Bug 1259822 was meant to enable the pref for Nightly and DevEdition.

IS_NOT_RELEASE_OR_BETA was used for this, which sadly is false for DevEdition as its based on version number.

Assignee: nobody → arai.unmht
Status: NEW → ASSIGNED
Severity: -- → N/A
Priority: -- → P2

[Tracking Requested - why for this release]: We expected to have this in DevEdition for a while (but used the wrong flags to enable the pref) as it provides better errors for developers.

Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/959aa834fe50
Enable for javascript.options.property_error_message_fix on dev edition. r=njn
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Comment on attachment 9146751 [details]
Bug 1636195 - Enable for javascript.options.property_error_message_fix on dev edition. r?njn!

Beta/Release Uplift Approval Request

  • User impact if declined: This is only for dev edition.

Improved JavaScript error message isn't used on dev edition channel.
the error message previously caused compat issue and backed out (bug 1259822)
the intention here is to enable the improved error message only on nightly + dev edition in order to encourage devs to fix their code.

I've chosen "No" for "Has the fix been verified in Nightly?" question below, because the change in this patch affects only dev edition.
I've confirmed the fix on the binary from try run.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): The patch itself is low risk.
    the underlying change is known to cause some compat issue on some website, intentionally.
  • String changes made/needed:
Attachment #9146751 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Flags: needinfo?(arai.unmht)
Flags: needinfo?(arai.unmht)

Comment on attachment 9146751 [details]
Bug 1636195 - Enable for javascript.options.property_error_message_fix on dev edition. r?njn!

Uplift approved for the next beta, let's have QA verify the fix this time. Thanks.

Attachment #9146751 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Hi,
I checked on Fx 76.0.1 and Firefox Beta 77.0b5 and the javascript.options.property_error_message_fix component is set to false by default.
I verified on Dev Edition 77.0b5 and Nightly 78.0a1(2020-05-13) and the javascript.options.property_error_message_fix component is set to true by default.
Is this testing cover all scenarios?
If no, please send us more steps to test it.
Thanks.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: needinfo?(arai.unmht)

(In reply to Raluca from comment #8)

Hi,
I checked on Fx 76.0.1 and Firefox Beta 77.0b5 and the javascript.options.property_error_message_fix component is set to false by default.
I verified on Dev Edition 77.0b5 and Nightly 78.0a1(2020-05-13) and the javascript.options.property_error_message_fix component is set to true by default.
Is this testing cover all scenarios?
If no, please send us more steps to test it.
Thanks.

Yes, that covers all.
Thank you!

Flags: needinfo?(arai.unmht)
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.