Closed Bug 1636347 Opened 1 year ago Closed 1 year ago

Some glyphs in PDF garbled after a period of time

Categories

(Core :: Canvas: 2D, defect)

x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1607630
Tracking Status
firefox78 --- fixed

People

(Reporter: mt, Unassigned)

References

Details

Attachments

(2 files)

Attached image garbled.png

Reading crypto papers as PDF, which contain a lot of glyphs that aren't commonplace. Sometimes when I switch back to the tab containing the paper, the glyphs are replaced with placeholders. In this case, it appears to be the BMP fallback, but I have seen a simple box replacement also (perhaps something like □, U+24A1).

This is PDF rendering, so the text is being drawn to a canvas.

This is very hard to reproduce, but I managed to get a screenshot eventually; see attached. Reloading corrects it, after which it is hard to get back.

Attached image Expected

For reference, this is https://link.springer.com/content/pdf/10.1007%2F3-540-36492-7_7.pdf

I have seen this on other similar papers.

Component: Graphics: WebRender → Canvas: 2D

It might be worth filing this against pdf.js as well. It's not really clear who's fault it would be.

I'm pretty sure this will be a duplicate of bug 1607630.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1607630
You need to log in before you can comment on or make changes to this bug.