Last Comment Bug 163646 - allow a bookmark folder to be available from cascading Dock menu
: allow a bookmark folder to be available from cascading Dock menu
Status: VERIFIED FIXED
: relnote
Product: Camino Graveyard
Classification: Graveyard
Component: Bookmarks (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- enhancement with 6 votes (vote)
: ---
Assigned To: Simon Fraser
: sairuh (rarely reading bugmail)
Mentors:
Depends on: 178744
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 07:33 PDT by Craig Anderson
Modified: 2002-11-21 19:22 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Hack to add bookmarks to dockmenu (4.86 KB, application/octet-stream)
2002-10-04 15:32 PDT, cjd@concepthause.com
no flags Details

Description Craig Anderson 2002-08-20 07:33:29 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020724
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0) Gecko/20020724

Proposal: Bookmarks should be available from a cascading menu from the dock,
a-la SlashDock (http://homepage.mac.com/stas/slashdock.html). Large bookmark
collections will need to be handled..

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Greg K. 2002-08-20 09:39:15 PDT
I'll confirm as an RFE.
Comment 2 Simon Fraser 2002-08-20 11:50:04 PDT
I see UI issues looming here.
Comment 3 Mike Pinkerton (not reading bugmail) 2002-08-20 12:55:35 PDT
i'm certain this is a dupe of another bug
Comment 4 Craig Anderson 2002-08-21 04:33:52 PDT
Mike,
You may be remembering the post I made the the Chimera mailing list regarding
this issue. It took me a while to get around to entering this as a bug.
Comment 5 cjd@concepthause.com 2002-10-04 15:32:31 PDT
Created attachment 101759 [details]
Hack to add bookmarks to dockmenu

This is a small hack to the main menu .nib that adds a submenu that mirrors the
bookmark menu.
Comment 6 S Woodside 2002-10-09 22:30:06 PDT
Cool idea!
Comment 7 cjd@concepthause.com 2002-11-04 12:29:12 PST
Has there been any activity on this issue, or is it just not priority at this
time.  It is a pretty straight forward, and a ridiculously simple change to
implement, and it is apparently much desired by the Chimera community.

So where does it stand currently?
Comment 8 Simon Fraser 2002-11-04 13:12:32 PST
I experimented with this recently. My current thinking is to have an
id="dockmenu" on the <folder> in the XML which will be the root folder for the
dock menu, and to allow the user to set that via the Bookmarks Info window. By
default, we could set it to the bookmarks toolbar folder.
Comment 9 Simon Fraser 2002-11-06 15:23:24 PST
Fixed. In the bookmarks info window, you can now assign a folder to be the 'dock
menu' folder, and its bookmarks will show up in the dock menu. This defaults to
the toolbar folder.
Comment 10 Albert Kammerer 2002-11-10 16:29:23 PST
Interesting implementation, but shouldn't the folder selected have the name of
the folder in the dock menu with a submenu showing it's contents? An example of
this would be a "Toolbar Bookmarks" entry and then a submenu showing it's
contents. This would keep from flooding the menu with bookmarks from a folder
that has a large number of bookmarks.
Comment 11 cjd@concepthause.com 2002-11-10 19:28:58 PST
Yeah, that is exactly what my hack accmplished.  It retained folder structure, and added 
all the bookmarks, not just the bookmarks toolbar.
Comment 12 Simon Fraser 2002-11-10 22:20:06 PST
I wanted to avoid always having a submenu under the dock menu. If you want all
your dock BM items under one folder, it's easy to arrange your bookmarks to do that.
Comment 13 sairuh (rarely reading bugmail) 2002-11-11 14:15:11 PST
this particular feature has been implemented, and i vrfy that it works with the
2002.11.11.04 build on 10.2.1. allowing a given bookmarks folder to be
accessible from the Dock can be done via the checkbox in the Get Info window.
also, to be clear, only one bookmarks folder can be designated as such.

i'll go do some regression testing in a bit (bug 178744) to make sure other
bookmarking features are still fine.

Note You need to log in before you can comment on or make changes to this bug.