Closed Bug 1636747 Opened 1 year ago Closed 1 year ago

Whitespace unexpectedly disappears when typing in contenteditable

Categories

(Core :: DOM: Editor, defect, P1)

x86_64
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 blocking fixed

People

(Reporter: saschanaz, Assigned: masayuki)

References

(Regression)

Details

(Keywords: inputmethod, regression)

Attachments

(1 file)

  1. Open https://www-archive.mozilla.org/editor/midasdemo/
  2. Type "뮤 뮤 뮤 뮤 뮤 뮤" ("ab ab ab ab ab ab" in QWERTY)

Expected: "뮤 뮤 뮤 뮤 뮤 뮤"
Actual: "뮤뮤 뮤뮤 뮤뮤"

This is a quite recent regression but I can't bisect as somehow builds from mozregression can't repro this. It only happens on public Nightly releases and local debug builds.

Severity: -- → S3

This severely degrades editing experience on most websites with contenteditable and can be reproduced consistently on my two devices with/without fission.

Mozregression says it's a regression by Bug 503838.

Severity: S3 → S2
Regressed by: 503838
Assignee: nobody → masayuki
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: Whitespace unexpectedly disappears when typing Hangul in contenteditable → Whitespace unexpectedly disappears when typing in contenteditable
Duplicate of this bug: 1637139

A smaller test could be:

Expected:

  • "aaa a"

Actual:

  • "aaaa"

The patches for this bug become too bigger than the regressed patch. I'll post a backout patch instead.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Duplicate of this bug: 1637792
Duplicate of this bug: 1638726
Depends on: 1645257
You need to log in before you can comment on or make changes to this bug.