Open Bug 1636846 Opened 3 months ago Updated 1 month ago

picture-in-picture doesn't open in full-screen mode

Categories

(Toolkit :: Video/Audio Controls, defect, P1)

76 Branch
Desktop
Linux
defect

Tracking

()

REOPENED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: voytovich.slava, Assigned: stransky, NeedInfo)

Details

Attachments

(2 files)

Attached file environment_info

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

  1. Open youtube video
  2. Click on picture-on-picture link above the video
  3. Double-click on the picture-on-picture window

Actual results:

the picture-on-picture window doesn't turn to full-screen mode

Expected results:

The picture-on-picture window doesn't turn to full-screen mode as It said in the last Firefox Release Notes - "a double click can take the small window into full screen"

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit

Hi voytovich.slava,

When you double-click on the player window, instead of fullscreening the video, what does it do?

Flags: needinfo?(voytovich.slava)

Because this bug's Severity is normal and has not been changed, and this bug's priority is -- (none,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → --

Hi Mike Conley!
It does nothing. It keeps the same size as before double-click.

Flags: needinfo?(voytovich.slava)

Hey mstransky, do you see similar behaviour?

Flags: needinfo?(stransky)

Yes, I'll look at it.

Flags: needinfo?(stransky)
Assignee: nobody → stransky
Severity: -- → S2
OS: Unspecified → Linux
Priority: -- → P1
Hardware: Unspecified → Desktop
Pushed by malexandru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b52897fc2bd1
[Linux] Don't use window aspect ratio lock for fullscreen window, r=jhorak
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Flags: qe-verify+

I was unable to reproduce the issue, I tried with Firefox 76.0 on Ubuntu 16.04 x64.
Verified on Nightly 79.0a1 and Firefox 78.0b9 and the issue does not occur.

voytovich.slava, would you mind checking that the issue does not reproduce for you. You can download a build from here: https://www.mozilla.org/en-US/firefox/channel/desktop/

Flags: needinfo?(voytovich.slava)

(In reply to Gabi Cheta [:Gabi] Release Desktop QA from comment #10)

I was unable to reproduce the issue, I tried with Firefox 76.0 on Ubuntu 16.04 x64.
Verified on Nightly 79.0a1 and Firefox 78.0b9 and the issue does not occur.

voytovich.slava, would you mind checking that the issue does not reproduce for you. You can download a build from here: https://www.mozilla.org/en-US/firefox/channel/desktop/

I downloaded Beta (firefox-78.0b9) and Nightly (firefox-79.0a1.en-US.linux-x86_64) builds and tried them.
I still have the issue. I can't turn picture-in-picture to full screen mode.

Flags: needinfo?(voytovich.slava)

Per reporter issue is still reproducible. Reopening bug.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---

I'll look at it.

(In reply to Gabi Cheta [:Gabi] Release Desktop QA from comment #12)

Per reporter issue is still reproducible. Reopening bug.

Works for me in Gnome/Fedora32. Please open a new bug for it and attach your about:config. Also which distro and desktop environment do you use?

Flags: needinfo?(gasofie)
Flags: needinfo?(gasofie) → needinfo?(voytovich.slava)
You need to log in before you can comment on or make changes to this bug.