images in form not aligned

VERIFIED FIXED in M12

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: mats, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Have fix in my tree, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
In the specified page the "Log off IGM" image in the top navigation bar isn't
aligned with the rest of the images.
Bug occurs in mozilla nightly build 1999-10-13-13-M11 on Windows NT4 SP5.
Bug does not occur in Communicator 4.7 and IE4.
(Reporter)

Updated

18 years ago
Whiteboard: [TESTCASE]
(Reporter)

Comment 1

18 years ago
Created attachment 2154 [details]
testcase

Updated

18 years ago
Assignee: karnaze → kmcclusk

Comment 2

18 years ago
Reassigning to Kevin.
(Assignee)

Comment 3

18 years ago
The problem is the log off image is displayed using an <IMG> element. the other
images are displayed using <INPUT type=image> elements. The alignment for <INPUT
type=image> is vertical-align:bottom. The alignment is not set for <IMG> in
html.css. If I add the vertical-align:bottom to the img { } style rule the log
off image will display aligned with the other images. I checked Nav 4.61 and it
also aligns the <IMG> to the bottom.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Whiteboard: [TESTCASE] → Have fix in my tree
Target Milestone: M12
(Assignee)

Comment 4

18 years ago
Setting vertical-align:baseline for input[type=image] fixes this bug and makes
it compatible with Nav 4.61. Setting <img> to vertical-align:bottom is not
correct.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

18 years ago
Fixed in Oct 14, 1999 5:00PM build.

Updated

18 years ago
Status: RESOLVED → REOPENED

Updated

18 years ago
Resolution: FIXED → ---

Comment 6

18 years ago
Using the 1999111016 M11 build under NT 4 SP 5, both the original URL and the
testcase Bugzilla attachment do not show up correctly in Seamonkey. Reopening
and clearing resolution.
(Assignee)

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

18 years ago
Changed misspelled vertial-align to vertical-align for input[type=image] in
html.css

Comment 8

18 years ago
QA Contact update.

Comment 9

18 years ago
Marking VERIFIED FIXED on:
- Linux6 2000-03-07-09 Commercial build
- MacOS9 2000-03-07-08 Commercial build
- Win98 2000-03-07-09 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.