Closed Bug 1637385 Opened 1 year ago Closed 1 year ago

Various shadow-scheduler tweaks

Categories

(Firefox Build System :: Task Configuration, task)

task

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: ahal, Assigned: ahal)

References

(Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

Let's update our shadow-schedulers, get rid of the poor performers and replace them with some new experiments.

This feature A) scheduled way too many tasks, and B) won't be that useful anyway once we
switch to manifest-scheduling.

Depends on D75398

The bugbug_debug algorithm wasn't a very high performer, but combining it with
'disperse' may yield some interesting results.

Depends on D75399

Attachment #9149132 - Attachment description: Bug 1637385 - [taskgraph] Replace 'bugbug_debug' shadow-scheduler with 'bugbug_debug_disperse', r?marco → Bug 1636940 - [taskgraph] Replace 'bugbug_debug' shadow-scheduler with 'bugbug_debug_disperse', r?marco
Duplicate of this bug: 1636940
Attachment #9149132 - Attachment description: Bug 1636940 - [taskgraph] Replace 'bugbug_debug' shadow-scheduler with 'bugbug_debug_disperse', r?marco → Bug 1637385 - [taskgraph] Replace 'bugbug_debug' shadow-scheduler with 'bugbug_debug_disperse', r?marco
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f8e3742a6ca5
[taskgraph] Remove the bugbug 'combined' flag and related shadow-scheduler, r=marco
https://hg.mozilla.org/integration/autoland/rev/5a12d30f8019
[taskgraph] Replace 'bugbug_debug' shadow-scheduler with 'bugbug_debug_disperse', r=marco
https://hg.mozilla.org/integration/autoland/rev/4fc3e6dbedc1
[taskgraph] Add a 'bugbug_disperse_high' shadow scheduler, r=marco
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Attachment #9149128 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.