Closed Bug 16375 Opened 20 years ago Closed 19 years ago

[LAYER] -- see attachment -- Text is misplaced, overlapped and absent from the display of this page

Categories

(Tech Evangelism Graveyard :: English US, defect, P1, critical)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: john.pampuch, Assigned: evangelism)

References

()

Details

Attachments

(2 files)

When I view this page in mozilla (M10) on Win 98, I find that the content is
radically different from Nav 4.5, and clearly quite damaged.
Portions of the text (like whole paragraphs) are missing, and
numerous lines of text overlap each other.
Assignee: rickg → kipp
I don't see the problem; but I do see a crash in linebreaker. Reassinging to
kipp. Stacktrace given:

nsDebug::PreCondition(const char * 0x01a88910, const char * 0x01a88904,
  const char * 0x01a888d0, int 378) line 262 + 13 bytes
nsJISx4501LineBreaker::Next(nsJISx4501LineBreaker * const 0x017c7900, const
   unsigned short * 0x01d85ac0, unsigned int 2, unsigned int 2, unsigned int *
   0x00128cc8, int * 0x00128cd4) line 378 + 34 bytes
nsTextTransformer::GetNextWord(int 0, int & 1, int & 1, int & 1, int 1) line 241
  + 38 bytes
nsTextFrame::Reflow(nsTextFrame * const 0x01dd7854, nsIPresContext & {...},
   nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int &
   0) line 2662 + 38 bytes
nsLineLayout::ReflowFrame(nsIFrame * 0x01dd7850, nsIFrame * * 0x00129124,
unsigned int & 0) line 910
nsInlineFrame::ReflowInlineFrame(nsIPresContext * 0x017a8cc0, const
nsHTMLReflowState & {...}, nsInlineFrame::InlineReflowState & {...}, nsIFrame *
0x01dd7850, unsigned int & 0) line 1553 + 20 bytes
nsInlineFrame::ReflowInlineFrames(nsIPresContext * 0x017a8cc0, const
nsHTMLReflowState & {...}, nsInlineFrame::InlineReflowState & {...},
nsHTMLReflowMetrics & {...}, unsigned int & 0) line 1400 + 28 bytes
nsInlineFrame::Reflow(nsInlineFrame * const 0x01dd7c74, nsIPresContext & {...},
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, unsigned int & 0)
line 1316 + 31 bytes
nsLineLayout::ReflowFrame(nsIFrame * 0x01dd7c70, nsIFrame * * 0x00129d38,
unsigned int & 0) line 910
nsBlockFrame::ReflowInlineFrame(nsBlockReflowState & {...}, nsLineLayout &
{...}, nsLineBox * 0x01dd77d0, nsIFrame * 0x01dd7c70, unsigned char *
0x001292ec) line 3563 + 26 bytes
nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState & {...}, nsLineLayout &
{...}, nsLineBox * 0x01dd77d0, int * 0x00129bfc, unsigned char * 0x00129a90)
line 3454 + 28 bytes
nsBlockFrame::DoReflowInlineFramesAuto(nsBlockReflowState & {...}, nsLineBox *
0x01dd77d0, int * 0x00129bfc, unsigned char * 0x00129a90) line 3400 + 34 bytes
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 16656 ***
Status: RESOLVED → VERIFIED
Agreed. This is a duplicate of 16656.
Status: VERIFIED → REOPENED
Assignee: kipp → rickg
Status: REOPENED → NEW
I reopened the bug because the author indicated that the *layout* issues remain,
after the sillyness with the assertions was fixed. Assigning back to rick to
look into the messed up layout. It's probably a dup of some other problem
(either parser or layout).
Resolution: DUPLICATE → ---
Clearing DUPLICATE resolution due to reopen of this bug.
Assignee: rickg → harishd
Moving this bug to my list.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → INVALID
Summary: Text is mis placed, overlapped and absent from the display of this page → [LAYER] -- see attachment -- Text is mis placed, overlapped and absent from the display of this page
Invalidating LAYER related bug.
Marking verified invalid.
Status: RESOLVED → VERIFIED
Moving all [LAYER] bugs to Evangelism component for tracking and open-source
evangelism by mozilla community members of sites that need to upgrade to support 
web standards such as HTML 4.0 (instead of LAYER/ILAYER) and the W3C DOM
(instead of Nav4 document.layers[] or IE document.all()). Sites should be
lobbied to do the upgrade using the email templates that are linked to from
http://www.mozilla.org/newlayout/bugathon.html#layerbugs . When a site's owner
has confirmed receipt of the message requesting an upgrade, the bug should be
marked with the keyword evangelized to indicate that evangelism for that bug is
complete. When the site finishes the upgrade and supports standards, the bug
should be closed.
Assignee: harishd → nobody
Status: VERIFIED → NEW
Component: HTML Element → Evangelism
Keywords: evangwanted
QA Contact: petersen → nobody
Target Milestone: M14 → ---
Closing all Evangelism bugs where no evangelism is needed because page has been 
fixed, site is internal to Netscape, report is a DUP, or bug report is no longer 
appropriate for evangelism for any other reason.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
SPAM:Changing QA contact on 111 evang bugs as I am now the new QA contact for 
this component.

Sorry about the spam

zach
QA Contact: nobody → zach
Reassigning Evangelism bugs to me, the component's new owner.  I would like to 
take this opportunity to thank nobody@mozilla.org for all of his dedication, 
contributions, and hard work, and wish him luck at his new job.  Thanks, nobody.
Assignee: nobody → BlakeR1234
Status: RESOLVED → NEW
workaround bugzilla problem that caused a bunch of evangelism bugs to be 
NEW/INVALID, NEW/FIXED, NEW/WORKSFORME or NEW/DUPLICATE
Resolution: INVALID → ---
Severity: normal → critical
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: P3 → P1
Hardware: PC → All
Summary: [LAYER] -- see attachment -- Text is mis placed, overlapped and absent from the display of this page → [LAYER] -- see attachment -- Text is misplaced, overlapped and absent from the display of this page
Target Milestone: --- → mozilla0.6
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Status: ASSIGNED → NEW
Keywords: evangwanted
Target Milestone: mozilla0.6 → Future
pcweek.com was bought by zdnet.
Marking fixed as zdnet uses standards compliant code on the redirect link.
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Target Milestone: Future → ---
Version: other → unspecified
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.