form data not preserved on forward

VERIFIED FIXED in M11

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: dbaron, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

DESCRIPTION:  Form data is preserved if you click a link on the page with the
form and then hit "Back".  However, it isn't preserved if you hit "Forward" on
the page with the form and then hit back.

STEPS TO REPRODUCE:
 1) Load http://bugzilla.mozilla.org/query.cgi
 2) Put a name in the email field
 3) click on the "mozilla.org" link near the top
 4) click "Back".  The name's still there.
[repeat (3) and (4) if desired]
 5) click "Forward"
 6) click "Back"

ACTUAL RESULTS:  The name is gone.

EXPECTED RESULTS:  It should still be there.

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-10-13-12-M11

Updated

19 years ago
Assignee: karnaze → pollmann

Comment 1

19 years ago
I'll save Chris some time on this one.  I think this should go to Eric or Radha
because they worked on implementing the session history stuff.  Re-assigning
this to Eric first and ccing Radha.

Comment 2

19 years ago
Also does not work correctly on: 1999-10-12-16-M11 mozilla.exe on Windows NT

Updated

19 years ago
Assignee: pollmann → radha
OS: Linux → All
Hardware: PC → All

Comment 3

19 years ago
Radha, I'm betting this is yours.
When I reproduced this on yahoo.com, I got this printf:

nsLayoutHistoryState::GetState, ERROR getting History state for the key

Looking in nsLayoutHistoryState::GetState, this should only happen if the state
you fetch is null.  My guess is that it was released already?
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

19 years ago
Blocks: 17432
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Fixed. Please verify

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Verified in the 1999111016 M11 build under NT.

Updated

18 years ago
No longer blocks: 17432
You need to log in before you can comment on or make changes to this bug.