Layout of ftp page is extremely slow, slower than NOVA

VERIFIED FIXED

Status

()

P2
critical
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: glynn, Assigned: rickg)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Nov 24 build, raptor demo

1.  Launch xpviewer on NT or win95 machine, go to http://grok, and observe page
layout and especially time to do so....

•  Takes forever to layout just any ftp page.  Format is wrong as well but filed
as separate bug.  Non ftp pages scream in comparison, and NOVA of course screams
as well.  Need to fix for demo I believe.  Also noted virtual memory resources
are completely sucked away and grok would not run autoload sequence.  Will file
as separate bug, and if it is a dupe we can just mark it as such, but I want the
bases covered.

Updated

20 years ago
Status: NEW → ASSIGNED
Summary: ss: Layout of ftp page is extremely slow, slower than NOVA → Layout of ftp page is extremely slow, slower than NOVA

Comment 1

20 years ago
There is no way we can fix this for the developer release. It requires too many
changes to resolve. I have it *partially* fixed in my tree, but it is still
painfully slow (better than before).

I've removed the ss: tag, but left the bug alive.

Updated

20 years ago
Assignee: kipp → rickg
Status: ASSIGNED → NEW

Comment 2

20 years ago
I'm reassigning this to rickg for now: there is a parser bug on this page. Try
this simple test to see it in action. The parser is closing PRE sections when it
sees an HR. Bad bad parser... :-)

--CUT HERE--
<HTML>
 <BODY>
<PRE>
This is some pre text
<hr>
This should be in the pre too!
</PRE>
 </BODY>
</HTML>
--CUT HERE--

Comment 3

20 years ago
*** Bug 1637 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
Putting on rn: radar.
Summary: Layout of ftp page is extremely slow, slower than NOVA → rn:Layout of ftp page is extremely slow, slower than NOVA
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Summary: rn:Layout of ftp page is extremely slow, slower than NOVA → Layout of ftp page is extremely slow, slower than NOVA

Comment 5

20 years ago
Release Noted - removing from rn: radar.

Comment 6

20 years ago
*** Bug 1637 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED

Comment 7

20 years ago
glynn, please check against latest Viewer build.  Reopen if still slow.

Comment 8

20 years ago
glynn, could you please Verify this today?  Thanks!
(Reporter)

Updated

20 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

20 years ago
Ok it looks fixed in Jan 19 build, in terms that initial ftp page layout is much
speedier than it was, but me thinks more work as mentioned below is to be done.
Will file new bugs for other items.  Verified on Win98.
You need to log in before you can comment on or make changes to this bug.