Closed Bug 1638153 Opened 6 months ago Closed 4 months ago

Fix JS users of rootTreeItem

Categories

(Core :: DOM: Navigation, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla79
Fission Milestone M6a
Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: kmag, Assigned: kmag)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files, 1 obsolete file)

No description provided.
Severity: -- → S3
Fission Milestone: --- → M6a
Priority: -- → P3
Summary: Fix JS users or rootTreeItem → Fix JS users of rootTreeItem
See Also: → 1639107
Attachment #9149182 - Attachment description: Bug 1638153: Part 0 - Add Window.browsingContext getter. r=nika → Bug 1638153: Part 0 - Add Window.browsingContext getter. r=peterv
Attachment #9150222 - Attachment is obsolete: true
Duplicate of this bug: 1559478
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5a656842e241
Part 0 - Add Window.browsingContext getter. r=peterv
https://hg.mozilla.org/integration/autoland/rev/07ec713926c6
Part 1 - Add topChromeWindow getter to CanonicalBrowsingContext. r=nika
https://hg.mozilla.org/integration/autoland/rev/f7aedc92d396
Part 2 - Fix uses of .rootTreeItem to get top browser window. r=geckoview-reviewers,nika,snorp

That's probably a bad interaction between ChromeOnly and CrossOriginReadable.

We might need to filter out ChromeOnly properties in the codegen in CGCrossOriginProperties.

Depends on: 1643457

I put up a patch in bug 1643457 that should fix the failure from comment 7.

Kmag: I did land the fix for bug 1643457 two weeks ago, so you could try relanding this?

(In reply to Peter Van der Beken [:peterv] from comment #11)

Kmag: I did land the fix for bug 1643457 two weeks ago, so you could try relanding this?

I did, but apparently the landing failed and I didn't notice. I'll rebase and try again.

Flags: needinfo?(kmaglione+bmo)
Pushed by maglione.k@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/913b8e7489de
Part 0 - Add Window.browsingContext getter. r=peterv
https://hg.mozilla.org/integration/autoland/rev/911a985c6b73
Part 1 - Add topChromeWindow getter to CanonicalBrowsingContext. r=nika
https://hg.mozilla.org/integration/autoland/rev/ba4656e730c4
Part 2 - Fix uses of .rootTreeItem to get top browser window. r=geckoview-reviewers,nika,snorp
You need to log in before you can comment on or make changes to this bug.