Closed Bug 1638264 Opened 1 year ago Closed 1 year ago

Search bar width is not remembered

Categories

(Firefox :: Toolbars and Customization, defect)

78 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: Fanolian+BMO, Assigned: Gijs)

References

(Regression)

Details

(Keywords: nightly-community, regression, reproducible)

Attachments

(2 files)

Attached image Search bar width.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0
Build ID: 20200514211114

Steps to reproduce

  1. In a new profile, put search bar immediate next to address bar.
  2. Adjust the search bar width.
  3. Open a new (private) window. Or restart browser.

Actual result

Search bar width is reset to default. Please see attached screenshot.

Expected result

Customised search bar width is retained.

Flags: needinfo?(gijskruitbosch+bugs)

Actually the search bar width is not reset to default.
The width varies only if I have changed the search bar width before opening a new window.

(In reply to Fanolian from comment #2)

Actually the search bar width is not reset to default.
The width varies only if I have changed the search bar width before opening a new window.

I suspect the issue is that the width is relying on the xul persist store, and because the node is not in the DOM to start with, we never apply the persisted width.

Duplicate of this bug: 1638279
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/789aa5d87af7
fix search bar width getting lost due to it starting out in the palette, r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78

Fixed in Nightly 20200515215236. Thanks.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.