If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't attach signature from pipe (fifo)

VERIFIED DUPLICATE of bug 62993

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 62993
15 years ago
9 years ago

People

(Reporter: Jonas Stricker, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
hi!
like many people do, I use to attach a signature to my emails containing a
random generated fortune. on my machine (Linux 2.4.18-4GB i686, mozilla 1.1beta)
i created a little perl-script which re-fills a fifo-pipe, everytime the content
was read. the pipe is called ".signature" and I told the mozilla mailer to use
it as signature file. when I click on "compose", the mailer freezes as soon as
it tries to read from the pipe. that's astonishing to me, because all other
applications have no problems with reading from pipes. and as far as I know
fifo-pipes can be handled like "normal" files under *nix anytime.
perhaps is there any suggestion you can give me or already a work-around? also I
am very curious, why mozilla sees any difference between a pipe or a "regular" file.

kindest regards and congrats for a nice piece of software!
(excuse my broken english...)

jonas.---

Comment 1

15 years ago
see also http://bugzilla.mozilla.org/show_bug.cgi?id=73567#c16 (comment 16, 17
and 18)

Random signatures (chosen from a list of files) is in bug 162583

Most current work for signatures is in bug 37644, which would save signatures in
the profile-directory (and creade/edit/delete them in the mailviewer directly).

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 62993 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.