anchor (<a>) around image (<img>) vertical-align (css tag) move image out from the paragraph

RESOLVED DUPLICATE of bug 116762

Status

()

RESOLVED DUPLICATE of bug 116762
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: attinasi)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
if you enter an anchor tag in a style sheet (css):

a {
  font-family: Tahoma;
  font-size: 12px;
}

and in the body tag:

hello, test test, test more words... start
<a href="asdasda"><img src="abrakadabra.jpg" width="200" height="200" alt=""
title="abrakadabra"></a>
end more more more more more words


and the space beside "start" and "end" is 12px height, not 200 px. if needable
then I can reproduce it.

Comment 1

16 years ago
Created attachment 96215 [details]
testcase

wow, i'm pretty surprised this hasn't come up before.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: anchor (<a>) and style-sheets (css) → anchor (<a>) around image (<img>) resizes image with font-size style-sheets (css)
Not a DOM problem.
Assignee: jst → attinasi
Component: DOM HTML → Layout
QA Contact: stummala → petersen
(Reporter)

Comment 3

16 years ago
sorry! I did not test the bug before I sent it. therefore it was not valid. 
now, I tested it and here is the correct bug report.
Summary: anchor (<a>) around image (<img>) resizes image with font-size style-sheets (css) → anchor (<a>) around image (<img>) vertical-align (css tag) move image out from the paragraph in frameset
(Reporter)

Comment 4

16 years ago
sorry!
Summary: anchor (<a>) around image (<img>) vertical-align (css tag) move image out from the paragraph in frameset → anchor (<a>) around image (<img>) vertical-align (css tag) move image out from the paragraph

Comment 5

16 years ago
Comment on attachment 96215 [details]
testcase

bug morphed or I misunderstood.
Attachment #96215 - Attachment is obsolete: true

Comment 6

16 years ago
If I understand KARASZI and Waheed correctly, there were no problem.

--> INVALID
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

16 years ago
Created attachment 96446 [details]
this is a screenshot, for the bug

I think that nobody tests the bug, that I sent.
(Reporter)

Comment 8

16 years ago
Please download the screenshot and open the URL. You will see that is not an 
invalid bug
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 9

16 years ago
OK, sorry, now I see the same layout as your screenshot shows.
OS: Windows XP → All
Hardware: PC → All
Created attachment 96467 [details]
Testcase

*** This bug has been marked as a duplicate of 116762 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.