onChange triggered reload makes table change size visually

RESOLVED DUPLICATE of bug 131975

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 131975
16 years ago
15 years ago

People

(Reporter: Fredrik Öhrström, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When the user selects jump from the select box the table size
seems to be calculated twice and the middle calculation is actually 
rendered visually.

This results in the table changing size rapidly and annoyingly, ie
the text jumps around.

When the exact same page is reached through the link instead of 
onChange/Submit, it does not jump.

My browser:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Comment 1

16 years ago
confirmed the same behavior with linux build 20020821, but I think there is
another bug about form buttons doing weird things with layout.  I can't find it
now.  :(

The bug also occurs if you change the <select> to a <button> or a submit <input>
and then just press the button (you don't have to actually submit the form, just
press the button).  Perhaps that will jog someone's memory.

marking NEW for now
==> HTML Form Controls
Assignee: asa → rods
Status: UNCONFIRMED → NEW
Component: Browser-General → HTML Form Controls
Ever confirmed: true
QA Contact: asa → tpreston

Comment 2

16 years ago
-->
Assignee: rods → jkeiser
(Assignee)

Comment 3

15 years ago
Testcase gone.  Could we get another, perchance?
(Reporter)

Comment 4

15 years ago
Created attachment 108869 [details]
Download this html to test.html on your local drive. Load it from there, click link or change option to demonstrate bug.

The old testcase can no longer be hosted on our server. This file
can be loaded from the local filesystem and demonstrates the bug
just as good.
(Reporter)

Comment 5

15 years ago
Comment on attachment 108869 [details]
Download this html to test.html on your local drive. Load it from there, click link or change option to demonstrate bug.

><HTML><HEAD/>
><BODY>
><FORM name="xyz" method="get" action="test.html">
>
><TABLE align="left">
><TBODY><TR><TD bgcolor="lightblue">
>
>    <!-- If this table  is removed, no jumping occurs -->
>    <TABLE width="50" align="left"><TBODY><TR><TD height="50"> </TD></TR></TBODY></TABLE>    
>
>    <TABLE>
>        <TBODY><TR><TD width="150">
>            <SELECT name="test" onchange="document.xyz.submit()"><OPTION value="0" selected="selected">Choose</OPTION><OPTION value="1">Jump</OPTION></SELECT><P>
>        <A href="test.html?test=1">No jump.</A>
>        </P></TD></TR>
>    </TBODY></TABLE>
>
></TD></TR></TBODY></TABLE>
>
>This text jumps around!
>
></FORM>
>
></BODY></HTML>
Attachment #108869 - Attachment description: Browse test.html, click link or change option to demonstrate bug. → Download this html to test.html on your local drive. Load it from there, click link or change option to demonstrate bug.
Attachment #108869 - Attachment mime type: text/html → text/plain
(Assignee)

Updated

15 years ago
Attachment #108869 - Attachment mime type: text/plain → text/html
(Assignee)

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 131975 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.