Closed Bug 1638724 Opened 4 months ago Closed 3 months ago

Intermittent org.mozilla.geckoview.test.WebExtensionTest.testBrowserTabsCreateWithCookieStoreId | org.mozilla.geckoview.GeckoResult$UncaughtException: java.lang.AssertionError: expected:<WebExtension

Categories

(GeckoView :: General, defect, P5)

Unspecified
All
defect

Tracking

(firefox78 wontfix, firefox79 fixed, firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox78 --- wontfix
firefox79 --- fixed
firefox80 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: agi)

Details

(Keywords: assertion, intermittent-failure)

Attachments

(1 file)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=302653825&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/W-Qx5HZgR3yyovbxeBP6Jg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-05-17T22:19:47.695Z] 22:19:47 INFO - TEST-START | org.mozilla.geckoview.test.WebExtensionTest.testBrowserTabsCreateWithCookieStoreId
[task 2020-05-17T22:20:12.647Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=722
[task 2020-05-17T22:20:12.647Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2020-05-17T22:20:12.647Z] 22:20:12 INFO - org.mozilla.geckoview.test | Error in testBrowserTabsCreateWithCookieStoreId(org.mozilla.geckoview.test.WebExtensionTest):
[task 2020-05-17T22:20:12.648Z] 22:20:12 INFO - org.mozilla.geckoview.test | org.mozilla.geckoview.GeckoResult$UncaughtException: java.lang.AssertionError: expected:<WebExtension {location=resource://android/assets/web_extensions/tabs-create-2/, id=tabs-create-2@tests.mozilla.org, flags=0}> but was:<WebExtension {location=, id=tabs-create-2@tests.mozilla.org, flags=0}>
[task 2020-05-17T22:20:12.648Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.dispatchLocked(GeckoResult.java:681)
[task 2020-05-17T22:20:12.648Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.completeExceptionally(GeckoResult.java:825)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$thenInternal$2$GeckoResult(GeckoResult.java:507)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$gwCgOUK_EYQn2g6GolfZvo6A_WE.run(lambda)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$dispatchLocked$3(GeckoResult.java:695)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$PehjG2jgyDa_p37vZrKrSi2I94s.run(lambda)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:751)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:95)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.waitForCondition(UiThreadUtils.java:155)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.waitForResult(UiThreadUtils.java:80)
[task 2020-05-17T22:20:12.649Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForResult(GeckoSessionTestRule.java:2285)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.WebExtensionTest.testBrowserTabsCreateWithCookieStoreId(WebExtensionTest.kt:562)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at androidx.test.internal.runner.junit4.statement.RunBefores.evaluate(RunBefores.java:80)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$2.lambda$evaluate$0$GeckoSessionTestRule$2(GeckoSessionTestRule.java:1293)
[task 2020-05-17T22:20:12.650Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.-$$Lambda$GeckoSessionTestRule$2$sIbRNaZJgAu-QrUVWSGD8JbPSWM.run(lambda)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1950)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:751)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:95)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:154)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:6077)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:866)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:756)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | Caused by: java.lang.AssertionError: expected:<WebExtension {location=resource://android/assets/web_extensions/tabs-create-2/, id=tabs-create-2@tests.mozilla.org, flags=0}> but was:<WebExtension {location=, id=tabs-create-2@tests.mozilla.org, flags=0}>
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.fail(Assert.java:88)
[task 2020-05-17T22:20:12.651Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.failNotEquals(Assert.java:834)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertEquals(Assert.java:118)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertEquals(Assert.java:144)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.WebExtensionTest$testBrowserTabsCreateWithCookieStoreId$tabDelegate$1.onNewTab(WebExtensionTest.kt:554)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.newTab(WebExtensionController.java:1014)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.newTab(WebExtensionController.java:990)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.lambda$handleMessage$7$WebExtensionController(WebExtensionController.java:864)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$WebExtensionController$3T2fcC_aERbyfXVDBquuPEGXvik.accept(lambda)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$accept$0(GeckoResult.java:425)
[task 2020-05-17T22:20:12.652Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$I3k4K0DCRrX6z4p5VGaRoaRBTZM.onValue(lambda)
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$thenInternal$2$GeckoResult(GeckoResult.java:493)
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | ... 25 more
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test |
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=testBrowserTabsCreateWithCookieStoreId
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.WebExtensionTest
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stack=org.mozilla.geckoview.GeckoResult$UncaughtException: java.lang.AssertionError: expected:<WebExtension {location=resource://android/assets/web_extensions/tabs-create-2/, id=tabs-create-2@tests.mozilla.org, flags=0}> but was:<WebExtension {location=, id=tabs-create-2@tests.mozilla.org, flags=0}>
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.dispatchLocked(GeckoResult.java:681)
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.completeExceptionally(GeckoResult.java:825)
[task 2020-05-17T22:20:12.653Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$thenInternal$2$GeckoResult(GeckoResult.java:507)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$gwCgOUK_EYQn2g6GolfZvo6A_WE.run(lambda)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$dispatchLocked$3(GeckoResult.java:695)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$PehjG2jgyDa_p37vZrKrSi2I94s.run(lambda)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:751)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:95)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.waitForCondition(UiThreadUtils.java:155)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.util.UiThreadUtils.waitForResult(UiThreadUtils.java:80)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule.waitForResult(GeckoSessionTestRule.java:2285)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.WebExtensionTest.testBrowserTabsCreateWithCookieStoreId(WebExtensionTest.kt:562)
[task 2020-05-17T22:20:12.654Z] 22:20:12 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:50)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.model.ReflectiveCallable.run(ReflectiveCallable.java:12)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.runners.model.FrameworkMethod.invokeExplosively(FrameworkMethod.java:47)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.internal.runners.statements.InvokeMethod.evaluate(InvokeMethod.java:17)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at androidx.test.internal.runner.junit4.statement.RunBefores.evaluate(RunBefores.java:80)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.GeckoSessionTestRule$2.lambda$evaluate$0$GeckoSessionTestRule$2(GeckoSessionTestRule.java:1293)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.rule.-$$Lambda$GeckoSessionTestRule$2$sIbRNaZJgAu-QrUVWSGD8JbPSWM.run(lambda)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.app.Instrumentation$SyncRunnable.run(Instrumentation.java:1950)
[task 2020-05-17T22:20:12.655Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.handleCallback(Handler.java:751)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Handler.dispatchMessage(Handler.java:95)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.os.Looper.loop(Looper.java:154)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at android.app.ActivityThread.main(ActivityThread.java:6077)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at java.lang.reflect.Method.invoke(Native Method)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:866)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:756)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | Caused by: java.lang.AssertionError: expected:<WebExtension {location=resource://android/assets/web_extensions/tabs-create-2/, id=tabs-create-2@tests.mozilla.org, flags=0}> but was:<WebExtension {location=, id=tabs-create-2@tests.mozilla.org, flags=0}>
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.fail(Assert.java:88)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.failNotEquals(Assert.java:834)
[task 2020-05-17T22:20:12.656Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertEquals(Assert.java:118)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.junit.Assert.assertEquals(Assert.java:144)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.test.WebExtensionTest$testBrowserTabsCreateWithCookieStoreId$tabDelegate$1.onNewTab(WebExtensionTest.kt:554)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.newTab(WebExtensionController.java:1014)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.newTab(WebExtensionController.java:990)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.WebExtensionController.lambda$handleMessage$7$WebExtensionController(WebExtensionController.java:864)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$WebExtensionController$3T2fcC_aERbyfXVDBquuPEGXvik.accept(lambda)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$accept$0(GeckoResult.java:425)
[task 2020-05-17T22:20:12.657Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.-$$Lambda$GeckoResult$I3k4K0DCRrX6z4p5VGaRoaRBTZM.onValue(lambda)
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | at org.mozilla.geckoview.GeckoResult.lambda$thenInternal$2$GeckoResult(GeckoResult.java:493)
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | ... 25 more
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test |
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=678
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: -2
[task 2020-05-17T22:20:12.658Z] 22:20:12 WARNING - TEST-UNEXPECTED-FAIL | org.mozilla.geckoview.test.WebExtensionTest.testBrowserTabsCreateWithCookieStoreId | org.mozilla.geckoview.GeckoResult$UncaughtException: java.lang.AssertionError: expected:<WebExtension {location=resource://android/assets/web_extensions/tabs-create-2/, id=tabs-create-2@tests.mozilla.org, flags=0}> but was:<WebExtension {location=, id=tabs-create-2@tests.mozilla.org, flags=0}>
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - TEST-INFO took 24958ms
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: numtests=722
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: stream=
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: id=AndroidJUnitRunner
[task 2020-05-17T22:20:12.658Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: test=testSetTabActiveNotAllowedInPrivateBrowsing
[task 2020-05-17T22:20:12.659Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: class=org.mozilla.geckoview.test.WebExtensionTest
[task 2020-05-17T22:20:12.659Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS: current=679
[task 2020-05-17T22:20:12.659Z] 22:20:12 INFO - org.mozilla.geckoview.test | INSTRUMENTATION_STATUS_CODE: 1

Assignee: nobody → agi
Status: NEW → ASSIGNED
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca9ad40caa79
Check for extension id instead of extension. r=esawin
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/39d2bb3d03b2
Check for extension id instead of extension. r=esawin

Thanks! Sorry about that.

Flags: needinfo?(agi)
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
You need to log in before you can comment on or make changes to this bug.