Closed Bug 1638786 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::dom::MediaPlaybackStatus::UpdateMediaPlaybackState]

Categories

(Core :: Audio/Video: Playback, defect, P3)

x86_64
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: gsvelto, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-58284d69-9b73-41b5-ba7f-d55030200515.

Top 10 frames of crashing thread:

0 xul.dll mozilla::dom::MediaPlaybackStatus::UpdateMediaPlaybackState dom/media/mediacontrol/MediaPlaybackStatus.cpp:19
1 xul.dll mozilla::dom::MediaStatusManager::NotifyMediaPlaybackChanged dom/media/mediacontrol/MediaStatusManager.cpp:242
2 xul.dll mozilla::dom::MediaController::NotifyMediaPlaybackChanged dom/media/mediacontrol/MediaController.cpp:131
3 xul.dll mozilla::dom::ContentParent::RecvNotifyMediaPlaybackChanged dom/ipc/ContentParent.cpp:5800
4 xul.dll mozilla::dom::PContentParent::OnMessageReceived ipc/ipdl/PContentParent.cpp:11566
5 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2110
6 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1989
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1211
8 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:109
9 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308

The crash is triggered by the MOZ_DIAGNOSTIC_ASSERT(mPlayingMediaNum < mControlledMediaNum) assertion. This seems to have started with buildid 20200514094044. For now we have crashes from at least 3 different installations, all on Windows 10.

It looks like this assertion was added in bug 1633010.

Flags: needinfo?(alwu)
Regressed by: 1633010
Has Regression Range: --- → yes

I've noticed this crash and submited a patch in bug1627999 which was landed on 5/16. So far we don't see any crash happens on the version later than 5/16. I will keep my eyes on it to see if the crash still exists or not.

Set release status flags based on info from the regressing bug 1633010

Set it as P3 for now to remove it from the untriaged bug.

Severity: -- → S3
Priority: -- → P3

Close this bug because this crash is fixed by bug1627999 and we didn't see any crashes on the build later than 5/16. Feel free to reopen if this crash happen again.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(alwu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.