mousewheel scroll with ATI graphics drivers hangs system

RESOLVED DUPLICATE of bug 101055

Status

--
critical
RESOLVED DUPLICATE of bug 101055
16 years ago
10 years ago

People

(Reporter: tab27, Assigned: asa)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: caused by ATI graphics drivers version 5.13.01.6118, URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020821
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020821

Scrolling with the mousewheel or by dragging the scrollbar through a long
unordered list brings the system to a halt.  No bluescreen, no talkback.  The
cursor responds but nothing else does, and if I click a few times a get a single
'beep' from the PC speaker and everything freezes.  CTL-ALT-DEL does nothing,
the only solution is a hard reset.

Scrolling with PgUp/PgDn or spacebar or by clickingthe space above or below the
scrollbar (whatever you call that) does not reproduce the bug.  Playing with the
mousewheel settings in mozilla had no effect.

Reproducible: Always

Steps to Reproduce:
1. Load a page with an unordered list (see URL for an example I made up)
2. Scroll with mousewheel or drag scrollbar.
3. hit reset button :-(

Actual Results:  
System freezes.  I get a few artifacts in the text being scrolled, like half a
line of text repeated twice.

Expected Results:  
Scroll normally.

System: Windows 2000 Professional build 2195, SMP (dual Athlon MPs), 512MB
ECC/reg RAM, ATI Radeon 8500 128MB, MS Trackball Explorer, all with latest drivers.

Comment 1

16 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020818

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
WFM 2002082008/trunk/W2K
(Reporter)

Comment 3

16 years ago
Bug has been independently reproduced by bonzo@vnet.net.  We are both using the
ATI Radeon 8500 graphics cards on AMD Athlon/Windows 2000 platforms.  I'm told
it maybe be an issue with ATI's newest drivers (v6118).

Further testing has shown that list-style-types circle and disc are the only
styles that cause the crashes.  All others (including squares) work fine.
(Reporter)

Comment 4

16 years ago
To see Mozilla crash with list-style-type: circle lists:

http://www.pages.drexel.edu/~tab27/crashmozilla-circles.html
(Reporter)

Comment 5

16 years ago
Last one:  It's confirmed, the issue is with ATI's video drivers version 
5.13.01.6118.  Reverting back to version 5.13.01.6094 solves all the problems
given here.

Hopefully this is being added to the relnotes.

Comment 6

16 years ago
I will copy comment #5 to bug 101055.

*** This bug has been marked as a duplicate of 101055 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Browser-General → GFX Compositor
Keywords: crash → hang
Resolution: --- → DUPLICATE
Summary: scrolling through an unordered list crashes entire system (win2K) → mousewheel scroll with ATI graphics drivers hangs system
Whiteboard: caused by ATI graphics drivers version 5.13.01.6118
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.