Closed Bug 1638925 Opened 4 months ago Closed 3 months ago

Extend `events` MOZ_LOG module

Categories

(Core :: XPCOM, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

Details

Attachments

(6 files)

  1. introduce events:2 that show also the name of the runnable (nsINamed).
  2. add logging of promise microtasks

Depends on D79618

Depends on D79620

Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/84236f1b9064
Log promise microtasks dispatch-and-run, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/4ea2c9ceb540
Log runnables in message_loop, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/2c8b67413cd6
Log names of nsINamed runnables, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/e0fe5351fdf7
Log IPC messages, r=froydnj

Grrr.. had to rebase first..

Flags: needinfo?(honzab.moz)
Depends on: 1637500
Attachment #9157608 - Attachment description: Bug 1638925 - Flip `AutoTaskGuard` and `LogRunnable::Run` in `TaskQueue::Runner::Run` to have target thread available for possible "is on current thread" assertions in the body of the event, r=bholley → Bug 1638925 - Flip `AutoTaskGuard` and `LogRunnable::Run` and add `SerialEventTargetGuard` in `TaskQueue::Runner::Run` to ensure the queue has target assigned all the time and to log also dispatch from a destructor, r=jya
Duplicate of this bug: 1647409
Attachment #9157608 - Attachment description: Bug 1638925 - Flip `AutoTaskGuard` and `LogRunnable::Run` and add `SerialEventTargetGuard` in `TaskQueue::Runner::Run` to ensure the queue has target assigned all the time and to log also dispatch from a destructor, r=jya → Bug 1638925 - Ensure that the event gets destroyed within the guards r=jya
Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/93905b640eba
Log promise microtasks dispatch-and-run, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/f149c349deae
Log runnables in message_loop, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/44bb157af907
Log names of nsINamed runnables, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/855ec99f86d7
Log IPC messages, r=froydnj
https://hg.mozilla.org/integration/autoland/rev/331fd3b03fbe
Do not keep a raw pointer to an event in `LogTaskBase::Run` RAII class to avoid possible work with a released pointer, r=jya
https://hg.mozilla.org/integration/autoland/rev/2d39c8687769
Ensure that the event gets destroyed within the guards r=jya
You need to log in before you can comment on or make changes to this bug.