Closed Bug 1638979 Opened 11 months ago Closed 11 months ago

Convert 'mach raptor' to run with Python 3

Categories

(Testing :: Raptor, task)

task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1520458

People

(Reporter: KrisWright, Unassigned)

References

Details

mach raptor still runs with python 2 [1]. We want to convert all mach commands to python 3.

To do this, any dependencies of the command may need to be converted as well as the command itself.

[1] https://searchfox.org/mozilla-central/rev/9193635dca8cfdcb68f114306194ffc860456044/testing/raptor/mach_commands.py

What's the difference to mach raptor-test? Should we just get rid of this mach command?

Flags: needinfo?(gmierz2)
Flags: needinfo?(dave.hunt)

I believe they're the same. Isn't this a dupe of bug 1520458?

Flags: needinfo?(dave.hunt) → needinfo?(kwright)

(In reply to Dave Hunt [:davehunt] [he/him] ⌚BST from comment #2)

I believe they're the same. Isn't this a dupe of bug 1520458?

Looks like it! I'll resolve these as duplicates and have bug 1520458 block bug 1577599.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(kwright)
Resolution: --- → DUPLICATE
Duplicate of bug: 1520458

Yes, they're the same thing.

Flags: needinfo?(gmierz2)
You need to log in before you can comment on or make changes to this bug.